1

I've been trying to disable Windows 10 Pro (Build 15063) from prompting for my password when my computer wakes up for a while now, and can't figure it out.

I have a few PCs joined to a Windows domain (2 x 2016 DCs) and tried setting a GPO to disable the Require a password when a computer wakes (plugged in) (and also the '' battery one) setting under Computer Configuration > Administrative Templates > System > Power Management > Sleep Settings.

The policy gets applied properly on my PCs, but whenever I put a PC to sleep, it asks for my password no matter what.

Here's the results of rsop:

rsop

Looking at the Sign-in options screen, I see the following, and cannot change it. It stays as Authentication is required when this PC wakes from sleep (in red) even if I remove all policies related to authentication (I even tried to clear all GPOs):

Sign-in options

I'm kind of dumbfounded at this point and ready to call this a Windows bug. Does anyone have any clue?

Edit 1 Tried to re-format my main PC. It allowed me to pick not to require a password in the Sign-in screen before I joined the domain, as expected (and didn't require a password on wake up). As soon as I've joined my domain, I was unable to pick an option (as expected, but I was required a password on wake up).

I used dcgpofix to reset my main DC policies, and disabled all of my policies. I still couldn't select the option within the Sign-in settings screen. It did allow me to select not to require a password within Power Options, but it keeps on asking me a password.

  • 1
    AD trumps local settings. – user772515 Nov 3 '17 at 2:37
  • @MichaelBay Yep, I know, that's why I'm getting that red message at the top. But as the rsop results shows, this is applied at the AD level (GPO). So in theory (if I understand the policy correctly), this should allow me to login without a password. That policy is set in the GPO, and is being applied to the PCs. – jValdron Nov 3 '17 at 2:44
0

I found out using gpresult that there is a setting being configured in Group Policy by domain controllers running in Windows Server 2012 or later (Computer ConfigurationWindows SettingsLocal PoliciesSecurity Options) called "Interactive Logon: Machine Inactivity Limit" that is by default set at 900 seconds/15 minutes (default by MS I guess...).

Changing this value to a 0 and disabling the require password on logon in the power management section of the Local Group Policy did the trick for me.

Now all of my Windows 10 machines are showing the following, with no more grumpy users:

Screenshot of Sign-in options

  • Thanks, I'll give it a try when I have a chance. For the time being I have a script that runs as my user on a remote server and unlocks the machine when it wakes up. Fugly but it works ;) – jValdron Aug 15 '18 at 14:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.