How do I delete a background wallpaper for Windows 10?

What I've done so far:

  1. Right click on desktop
  2. Select Personalize

I can choose another image but I can't remove the one that was recently added.

I've attached a screenshot:

enter image description here

I can change it but it still shows up in the recent history and slideshows so I want to completely remove it.

Given the related question on how to find the path to a wallpaper (a transcoded image), I've deleted the image and then restarted and the wallpaper image is still there in Wallpaper options and still there after a restart.

Given the update by @magnus I found the registry filled with background history. In that background history was the entry for the custom desktop wallpaper. I'm going to delete the entry and see how that goes.

Here is an image of the registry:

enter image description here

  • 1
    Possible duplicate of Path to current desktop backgrounds in Windows 10?. Flagged as a duplicate based on the answer by Magnus – Ramhound Nov 3 '17 at 15:10
  • Not a duplicate since I'm asking how to delete the file. I've found the path and deleted the file but it's still showing up in Wallpaper panel – daft2039480 Nov 3 '17 at 15:22
  • Are you saying the transcoded file reappears, or that the image thumbnail still shows in the list of desktop backgrounds? – music2myear Nov 3 '17 at 16:14
  • @music2myear Yes. Both. The trancoded file reappears after some time but not right away. – daft2039480 Nov 3 '17 at 16:24

The answer in this question might give you some locations you can try and look for the wallpaper you want to remove.

Update: You can also see the path to the wallpapers you have most recently used if you go to the registry key HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Wallpapers

Screenshot of registry entries: Registry entries

  • 1
    I found a TranscodedWallpaper in `%AppData%\Microsoft\Windows\Themes` and deleted it and restarted windows but it is restored after restart and still listed in Wallpapers screen. – daft2039480 Nov 3 '17 at 15:26
  • 1
    I've found the registry edits contained an entry for the wallpapers. I've deleted that entry and opened the Wallpaper Background control panel. It no longer shows the wallpaper. It was not selected at the time I removed the entry. It looks like it worked. I've attached a screenshot containing the registry entry in the main post. You can include it in your answer and I'll select it as the answer. For me the entry to delete was BackgroundHistoryPath1. If the user still has the image selected you might need to also select another wallpaper beforehand or update the CurrentWallpaperPath value. – daft2039480 Nov 3 '17 at 16:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.