Quick Background: iMac G5 (the white one; 4 years old?) Running Leopard 10.5.something. Time Machine started failing on me; and every time I touch the Finder, things beachball like crazy. Booting from install disk then using Disk Utility to "Repair Disk" also fails. I'm left with the conclusion that I have a corrupt file somewhere important, that's (i) keeping TM from working and (ii) messing with basic functionality. I am not (yet) savvy enough in OS X to know what logs to look in, or how to decipher them - but 'corrupt file' seems to be the likely case, based on my readings of apple.com forum threads.

So I think I need to backup, outside of Time Machine, then install fresh OS X on a new drive (or maybe SpinRite the current drive?).

I'm able to put a (non-Time Machine) external USB drive on, so I dragged all 3 Users' folders to that... am I done backing up? Am I going to have a massive Permissions problem, trying to put things back together after a re-install?

Thanks for reading.

UPDATE: What a mess. Yanokwa's definitely right that my drive is failing. When I got home, I hoped to make a SuperDuper back up per his suggestion. No dice ~ stuck on grey screen with twirly icon for 30 minutes. I guess my pulling our home directories last night was my last chance to interact with the drive.

Out of curiosity, I put my Leopard upgrade disk in and booted to it. Unlike it's usual behavior, it said "No OS X found, you can't upgrade." Ooof. Drive must really dead, right? I can't even take JRobert's advice and re-install OS X on the internal drive, recovering home folders from my last-second backup from yesterday.

Getting the drive out of this iSight G5 looks like more work than I'm up for, but I thought I might attempt to install OS X on an external drive. I've heard this is possible but have zero experience. I get my old Tiger disks out and boot to Disk 1. (For a lark I ran its version of "Disk Utility" also - locked up. So, reboot.) My old Time Machine drive was still attached, although it was my impression that I'd deleted my last TM backup. The Tiger install said "no internal drive, and I don't want to install to this external drive. It's not bootable." I despaired. I rebooted to the Tiger install disk and tried again, irrationally. This time, after 15 minutes of spinning, the installer said there was a disk available. This is where I get confused... I thought it said the External drive was available for install. I assumed I was putting a clean Tiger image on a USB drive. I check on it from time to time, watching the installer bar.

An hour later, I walk into the room and my 3 accounts are up, Leopard's hyperspace background and all. I click into my account. I immediately grab my wife's photos and drag them to a USB key. (Let's be honest; this whole drama is about those un-backed-up photos. I'm that guy.) I'm feeling jim-dandy, though I'm still not entirely sure what I've done. I have no doubt that the internal drive is mechanically iffy. I think the current live OS is living on the external drive - but I don't get how my current accounts are there.

Plan on having local Apple repair shop install a new drive for me, in the next few days. With photos safely offloaded, I don't really even care how I got here; just glad I did.

SECOND UPDATE: Fought with SuperDuper for a while; it refused to save on either of my external drives. I went over to my Windows setup and pulled a WD terabyte drive out. Connected it to iMac and pointed SuperDuper at it. While it obviously wouldn't copy straight over (wrong filesystem), and it wouldn't do a sparse image - I think I have it making a sparse bundle. So I may make out all right after all. SuperDuper FTW. Had it all along, never used it 'til tonight.


sounds to me like your hard drive is failing. i'd get a copy of super duper and use that to backup the entire drive. then run disk warrior and see if it can fix your problem.

  • You're right about the drive failing. See my edits above, and thanks. – rlbgator Apr 2 '10 at 1:33
  • SuperDuper! is not designed to work on failing drives. It usually gives up when it gets errors. The rationale is that once you have errors, the source is wholly suspect so doing a normal backup no longer makes any sense. SuperDuper! is a nice program, but it is just not the tool to try to grab “one last copy of whatever you can” from a disk that has already started to fail. I have heard that DiskWarrior is a nice tool for recovering files, but I have never used it. – Chris Johnsen Apr 2 '10 at 5:01
  • agreed that with super duper and a failing drive, it's not clear that data you get isn't corrupt. i'd open up your pictures to make sure they are actually there. given the failing drive, i would copy it with something more robust to bad sectors. superuser.com/questions/90799/… is a good start. finally, the more you mess with the drive, the more damage you may cause. if the data is really important, call drive savers. – yanokwa Apr 2 '10 at 13:39

If you can't or don't want to do a full backup, you can at least restore your user folders to a newly installed system to recover your data and preferences. System wide preferences and configurations would need to be reset.

If that's the route you choose, you need only restore the 3 user accounts to the /Users folder of the new installation, and create 3 new user accounts with short-names matching the user-folder names. The OS will notice that a like named account already exists and will offer the option to use that account rather than creating a new one.

  • I had an uglier problem than I thought, but thanks for the info about linking to named accounts. That was re-assuring. – rlbgator Apr 2 '10 at 1:34

Another option is:

  1. Replace the current disk with a new one
  2. Install OS X on the new drive
  3. Plug in the old disk using a external USB enclosure
  4. Run Migration Assistant to copy user folders and apps off of the old disk

This has the advantage of getting fresh copies of all of the OS files, while coping as much of the User and Application data as possible from the old drive.

  • This makes sense. I don't have the nerve to get this iSight open myself, but when I have drive repaired, I'll go in this direction. (As I mention in my edit, my wife's photos were honestly the one piece of User Data I was panicked about.) – rlbgator Apr 2 '10 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.