32

I've updated my VLC Player on the Mac and now I have two windows for one video. How can I disable this, so it works the old way? enter image description here

1
  • 2
    Amazing how any given solution below is not entirely fixing the actual issue, still in 2022.
    – kissu
    Commented May 3, 2022 at 2:01

12 Answers 12

28

Tried all of the answers above, nothing worked BUT this did on Ubuntu 22.04:

switch Tools > Preferences > Video > Output to "X11 video output"

solution screenshot

source: last answer of https://www.linux.org/threads/opening-a-video-file-with-vlc-opens-two-seprate-windwos-screenshot-included.34753/

3
  • 1
    Also worked on Fedora 36
    – Sajjad
    Commented Jul 22, 2022 at 17:40
  • Worked on Debian testing
    – klutt
    Commented Jul 25, 2022 at 21:32
  • 2
    Works for me in Ubuntu 22.04.1 LTS. Finally.
    – Mena
    Commented Oct 11, 2022 at 20:10
15

In Preferences -> Interface, check Allow only one Instance

2
  • 4
    This is unrelated - it is only one instance of VLC. It just has two windows. @heavyd's answer is the right one.
    – Timmmm
    Commented Jun 9, 2022 at 18:37
  • 1
    This problem still happens even with "Allow only one instance" enabled. Commented Jun 21, 2022 at 19:46
7

In the VLC preferences under the Interface section check the box for Integrate video in interface (In older versions this option was labeled Embed video in interface)

3
  • 1
    For me it was already checked, but unchecking it and checking it again fixed the issue. Must be some preferences bug.
    – Timmmm
    Commented Jun 9, 2022 at 18:37
  • I can't find this checkbox in the latest version of VLC. Commented Jun 21, 2022 at 19:48
  • @AaronFranke looks like the option has changed to "Integrate video in interface"
    – heavyd
    Commented Jun 21, 2022 at 20:21
5

For me, setting "Number of clones" = 1 fixed this exact issue

Tools > Preferences > All > Video Splitters > Clone > Number of clones = 1

1
  • This is the only thing that worked! Thank you for this. Commented Jul 13, 2022 at 13:02
3

In the VLC preferences under the audio tab make sure visualization is set to default. This solved my problem of the visualizer window appearing on top of the video window.

2

Great answers but none of these worked for me. Must be a bug. Doesnt behave rationally.

  1. View -> Docked playlist [x]
  2. View -> Playlist (playlist is now visible) -> Press Stop, to stop the video -> Double click the item in your playlist, so the video will start
  3. View -> Playlist (playlist is now hidden and video is inside VLC main interface.
2

I don't know if this would help anyone, but since it worked for me, I share it here:

Tools > Preferences > Video > Display

Disable the "Window decorations" check box

P.S: I only tested this on Linux (Debian testing with Gnome and X11).

1
  • Worked for me on Ubuntu 20.04.
    – s.ouchene
    Commented Oct 31, 2022 at 18:37
1

In case it might help someone else. I'm running ubuntu 22 and most of the times the video would open in a separate window, rarely it would work as intended.

What solved it is under tools > preferences > interface: check 'Integrate video in interface' but remove the check on 'Resize interface to video size'.

I had tried all the solutions in this thread but none were working, this seems to have solved it.

1

tools > preferences > interface: UNcheck 'Integrate video in interface'

then closing the app reopening and (checking again)

tools > preferences > interface: check 'Integrate video in interface' again

worked for me

0

When you upgrade, under the Preferences > Interface tab, you should see an option Show video within the main window. It should be checked.

If you still have multiple windows, the VLC download package has a separate app under the Goodies folder called Delete VLC Preferences.app. Run that and try again.

0

To get rid of split video windows, under preferences, (show all), video, splitters, deselect split modes! (OSX High Sierra)

0

open VLC and press on "Ctrl + P" > Interface, check the box Allow only one Instance

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .