0

Preliminary warnings of disk communication errors

For some time now, I have been observing errors in the output of dmesg on my Samsung 900x laptop with Ubuntu 16. I've posted a sampling of typical errors below. When these errors occur, the machine takes notably longer to boot, which I conceptually understand as the machine struggling to maintain a link the the hard drive.

SMART monitoring did not indicate any problems with the disk.

From the answer to a similar question and from the linked wiki on unix stack exchange, I got the sense that these dmesg errors are indicating a communication failure.

Sample dmesg errors:

[   10.647713] ata1.00: exception Emask 0x1 SAct 0x38000000 SErr 0x400001 action 0x0
[   10.647737] ata1.00: irq_stat 0x44000008
[   10.647752] ata1: SError: { RecovData Handshk }
[   10.647769] ata1.00: failed command: READ FPDMA QUEUED
[   10.647789] ata1.00: cmd 60/20:d8:00:31:cf/00:00:1d:00:00/40 tag 27 ncq dma 16384 in
[   10.647834] ata1.00: status: { DRDY }
[   10.647848] ata1.00: failed command: READ FPDMA QUEUED
[   10.647866] ata1.00: cmd 60/80:e0:28:31:cf/00:00:1d:00:00/40 tag 28 ncq dma 65536 in
[   10.647912] ata1.00: status: { DRDY }
[   10.647926] ata1.00: failed command: READ FPDMA QUEUED
[   10.647945] ata1.00: cmd 60/48:e8:b8:31:cf/00:00:1d:00:00/40 tag 29 ncq dma 36864 in
[   10.647991] ata1.00: status: { DRDY }
[   10.648675] ata1.00: configured for UDMA/133
[   10.648685] ata1: EH complete
[   41.991217] ata1.00: exception Emask 0x0 SAct 0x7 SErr 0x400001 action 0x6 frozen
[   41.991252] ata1: SError: { RecovData Handshk }
[   41.991269] ata1.00: failed command: READ FPDMA QUEUED
[   41.991289] ata1.00: cmd 60/48:00:b8:31:cf/00:00:1d:00:00/40 tag 0 ncq dma 36864 in
[   41.991334] ata1.00: status: { DRDY }
[   41.991347] ata1.00: failed command: READ FPDMA QUEUED
[   41.991366] ata1.00: cmd 60/80:08:28:31:cf/00:00:1d:00:00/40 tag 1 ncq dma 65536 in
[   41.991486] ata1.00: status: { DRDY }
[   41.991501] ata1: hard resetting link
[   42.306886] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[   42.307383] ata1.00: configured for UDMA/133
[   42.307403] ata1.00: device reported invalid CHS sector 0

Total failure

Without the time to investigate the problem further, I made sure my things were backed-up onto other devices, and continued to use the laptop.

However, recently the laptop died all together.

It boots, but prints failure to read/write to sector with some hex addresses and doesn't proceed any further.

This total failure happened after the battery suddenly stopped working. I'm not sure if this is just a coincidence. Although, there were no previous indications that the battery had trouble holding a charge. Now it only stays powered when plugged into the outlet. The charge light alternates between green and orange.


Main question

Given that the dmesg errors and related questions/answers indicate a communication problem, not necessarily a bad hard disk, and given that there appear to be no replaceable communication cables (see images below), is this fixable?


Hard disk:

hard disk

Hard disk slot:

place where hard disk plugs in

  • I would talk to the hard drive manufacturer about this. It may indicate a problem with the electronics or firmware. – Ignacio Vazquez-Abrams Nov 6 '17 at 18:14
  • I've had Hard Link ressetting errors related to an inadequate power supply that was very paintful (time spent) to figure out. So the actual cause of the errors can sometime be difficult to drive out. Yes, it is probably a connection error, but WHY is the hard question to answer. – Damon Nov 6 '17 at 20:47
  • @Damon, thanks; any recommended reading/links towards figuring out the "why"? – Chester Nov 6 '17 at 21:42
  • Nothing specific, This is a troubleshooting problem where you may not be provided with the necessary documentation to efficiently troubleshoot leaving you guessing, test and measuring, etc. Sorry! Mostly the true problem could be something seemingly unrelated on the surface and don't give up! I didn't know for sure my PS was the problem; I just researched, tried and tried, test and measured, thought and thought, and arrived at taking a risk buying a bigger better one and it solved my problem. – Damon Nov 6 '17 at 21:49
0

Your SSD (which is not a hard drive) is stuffed. The confusion you are having may down to the differences between a hard drive and SSD.

(This is almost certainly a problem with the SSD itself rather with the connection it has to the laptop).

  • I understand that it's a solid state drive. I was being imprecise with the terminology. Your answer isn't very helpful because it doesn't explain how you arrived at your conclusion that it's a disk error, not a connection error. – Chester Nov 6 '17 at 20:38
  • @ramhound - ta, I fixed that. – davidgo Nov 6 '17 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.