1

I'm using Open Media Vault 3 that is based on Debian 8.

I already have a RAID1 of 2x4TB WD Caviar Red, and now I'm tring to build a RAID1 with two Seagate Ironwolf 6TB.

Whe I build it anything is fine and I can create an ext4 partition on it and use it without a problem.

The problem is that every time that I reboot only the new RAID1 disappears. The old one is working just fine without any problem.

If I look with gparted both hard drives has no partion, like I never built a RAID1 with them, but if I look with testdisk I can find every file. Also if I try to rebuild the RAID the files will still be there, so I'm not losing my data.

After the reboot I tried to see if I could find md0 but this is the result:

mdadm --detail --scan

ARRAY /dev/md127 metadata=1.2 name=NAS:Data UUID=ed696fd2:96feba4f:ab44fb72:b800fb01

No md0, only 127! I also tried with this command:

root@Delibird:~# mdadm -Es
ARRAY /dev/md/Data  metadata=1.2 UUID=ed696fd2:96feba4f:ab44fb72:b800fb01 name=NAS:Data

and still no result.

This is the conf file (/etc/mdadm/mdadm.conf)

# mdadm.conf
#
# Please refer to mdadm.conf(5) for information about this file.
#

# by default, scan all partitions (/proc/partitions) for MD superblocks.
# alternatively, specify devices to scan, using wildcards if desired.
# Note, if no DEVICE line is present, then "DEVICE partitions" is assumed.
# To avoid the auto-assembly of RAID devices a pattern that CAN'T match is
# used if no RAID devices are configured.
DEVICE partitions

# auto-create devices with Debian standard permissions
CREATE owner=root group=disk mode=0660 auto=yes

# automatically tag new arrays as belonging to the local system
HOMEHOST <system>

# definitions of existing MD arrays
ARRAY /dev/md127 metadata=1.2 name=NAS:Data UUID=ed696fd2:96feba4f:ab44fb72:b800fb01
ARRAY /dev/md0 metadata=1.2 name=Delibird:Telefilm UUID=4de2d990:37fa60cf:b34e2c9e:63b4d0ca

I tried to update the conf for the boot with

update-initramfs -u

But even after that, the RAID1 is still missing after the reboot :(

I finally tried wit this command:

 mdadm --assemble --scan

but it did nothing

How should I do? I really don't know how to solve my problem!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.