2

I cannot install any packages with apt-get on Raspbian (Debian) because of stupid Python packages.

I tried to sudo dpkg --configure -a but even then I’m getting these errors!

Messages:

Setting up python3 (3.4.2-2) ...
running python rtupdate hooks for python3.4...
dpkg-query: package 'gdebi-core' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 210, in <module>
    main()
  File "/usr/bin/py3clean", line 196, in main
    pfiles = set(dpf.from_package(options.package))
  File "/usr/share/python3/debpython/files.py", line 53, in from_package
    raise Exception("cannot get content of %s" % package_name)
Exception: cannot get content of gdebi-core
error running python rtupdate hook gdebi-core
dpkg-query: package 'python3-uno' is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
Traceback (most recent call last):
  File "/usr/bin/py3clean", line 210, in <module>
    main()
  File "/usr/bin/py3clean", line 196, in main
    pfiles = set(dpf.from_package(options.package))
  File "/usr/share/python3/debpython/files.py", line 53, in from_package
    raise Exception("cannot get content of %s" % package_name)
Exception: cannot get content of python3-uno
error running python rtupdate hook python3-uno
dpkg: error processing package python3 (--configure):
 subprocess installed post-installation script returned error exit status 4
dpkg: dependency problems prevent configuration of python3-gi:
 python3-gi depends on python3 (>= 3.4~); however:
  Package python3 is not configured yet.
 python3-gi depends on python3 (<< 3.5); however:
  Package python3 is not configured yet.

dpkg: error processing package python3-gi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of unattended-upgrades:
 unattended-upgrades depends on python3; however:
  Package python3 is not configured yet.

dpkg: error processing package unattended-upgrades (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-software-properties:
 python3-software-properties depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.
 python3-software-properties depends on unattended-upgrades; however:
  Package unattended-upgrades is not configured yet.

dpkg: error processing package python3-software-properties (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dh-python:
 dh-python depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.

dpkg: error processing package dh-python (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of software-properties-common:
 software-properties-common depends on python3 (>= 3.2.3-3~); however:
  Package python3 is not configured yet.
 software-properties-common depends on python3-gi; however:
  Package python3-gi is not configured yet.
 software-properties-common depends on python3-software-properties; however:
  Package python3-software-properties is not configured yet.

dpkg: error processing package software-properties-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-apt:
 python3-apt depends on python3 (<< 3.5); however:
  Package python3 is not configured yet.
 python3-apt depends on python3 (>= 3.4~); however:
  Package python3 is not configured yet.

dpkg: error processing package python3-apt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3-dbus:
 python3-dbus depends on python3 (>= 3.3~); however:
  Package python3 is not configured yet.
 python3-dbus depends on python3:any (>= 3.3.2-2~); however:
  Package python3 is not configured yet.
 python3-dbus depends on python3 (<< 3.5); however:
  Package python3 is not configured yet.

dpkg: error processing package python3-dbus (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-software-properties:
 python-software-properties depends on unattended-upgrades; however:
  Package unattended-upgrades is not configured yet.

dpkg: error processing package python-software-properties (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python3
 python3-gi
 unattended-upgrades
 python3-software-properties
 dh-python
 software-properties-common
 python3-apt
 python3-dbus
 python-software-properties
4

Switch back to python 2.7

Use the command :

sudo update-alternatives --config python

If you get an error :

update-alternatives: error: no alternatives for python

Update your update-alternatives as follow :

ls /usr/bin | grep python | columns

sample output:

dh_python2  idle-python3.4  python2     python3     python3.4m
dh_python3  python      python2.7   python3.4   python3m

You have the python2.7 and python3.4 , run:

sudo update-alternatives --install /usr/bin/python python /usr/bin/python2.7 1
sudo update-alternatives --install /usr/bin/python python /usr/bin/python3.4 2

See update-alternatives --help

Now you can run;

sudo update-alternatives --config python

sample output:

There are 2 choices for the alternative python (providing /usr/bin/python).

  Selection    Path                Priority   Status
------------------------------------------------------------
* 0            /usr/bin/python3.4   2         auto mode
  1            /usr/bin/python2.7   1         manual mode
  2            /usr/bin/python3.4   2         manual mode

Press enter to keep the current choice[*], or type selection number: 1

To make the python2.7 as default select 1

Run :

sudo dpkg --configure -a
sudo apt update

use the command history to get the latest installed *-python package which break your system (e,g; python-scapy) then remove it:

sudo apt-get remove python-scapy

Once done you can revert back to python3.4 using the update-alternative command

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy