0

Whenever I try to move a file over 4 GB from my SSD to my external HDD, it says that the file is too large for my drive. I've heard multiple people say that I need to format my HDD to NTFS. The problem is just, that the HDD is ALREADY NTFS.

Is it because I need to change the size allocation unit? Mine is currently at 4096 bytes.

UPDATE:

Here's a picture of MY properties as you asked for:

MY properties

UPDATE 2:

Now it's real interesting. I did the command prompt things, and it states that it's FAT32 now. Weird. What should I do now?

I did the command prompt things, and it states that it's FAT32 now

  • 2
    Your drive is labelled FAT32 so it was probably that when you got it. Can you show disk properties to prove that it is actually ntfs? – Mokubai Nov 8 '17 at 7:36
  • 1
    @Mokubai thats not his drive.its a pic from google. – Keltari Nov 8 '17 at 7:38
  • Well duh, it would help if I read the link text... It would still be good to have proof that the drive is indeed ntfs as this is not a limitation I would expect to see even on a low cluster size. – Mokubai Nov 8 '17 at 7:40
  • Please edit your question and included the output from running fsutil fsinfo volumeinfo x: (where x is the drive letter for your external drive) in a cmd shell. – DavidPostill Nov 8 '17 at 8:45
  • 7
    The formatting tool has no business with the actual format of the drive. E.g. if you formatted your drive on linux, it would (most likely) be ext4. The formatting tool, however, would still show NTFS (standard), meaning "If you format the drive with me, I suggest you use NTFS for it." – flolilo Nov 8 '17 at 14:28
5

No, you do not need to change the default size allocation unit, but you do have to format it NTFS, since FAT32 does not support files over 4GB.

As for the actual size of the allocation unit, if you will copy a small number of very large files (i.e. movies), it helps being large (64kB) and if you want to copy a large number of small files (i.e. docs, pictures) it helps being small (4kB).

  • But the problem is.. It's already stated as being NTFS, so I really don't get it.... I never formatted my drive, this is how it came. – sredna Nov 8 '17 at 14:17
  • 1
    No, it's FAT32 in your initial screenshot. NTFS was what you want to format to. – Overmind Nov 9 '17 at 6:35
1

The first update with screen is what you want to do (format as NTFS), and not what you have.

Second screen clearly says, that the drive is formatted as FAT32.

What you need to do is move data from that drive (any filesystem operations could damage data on a drive, and formatting a drive removes all data from it) and then format it with the options from screen #1 - as NTFS.

After doing that you will be able to move files >4GB to that drive.

  • 1
    no need to do that. it's very easy to convert from FAT32 to NTFS without data loss. There are tons of question on this site telling how to do that – phuclv Nov 8 '17 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.