7

I have a ASUS ROG Strix GL702ZC laptop that comes with Windows 10 and a Precision Touchpad.

While using the touchpad I find that the two-finger smoothing is very smooth, but it comes with inertia that keeps scrolling a page shortly after you remove your fingers from the touchpad instead of stopping immediately, which is most likely a part of the smooth scrolling implementation. It's not a massive annoyance, but I believe it conflicts with some non-UWP applications (especially with games, where they can assume that you have scrolled the wheel like 30 clicks in a second).

I've had a look around in the Settings app but the only settings for scrolling that I've found are to do with enabling scrolling with two fingers, the speed that the page scrolls, and the direction the page scrolls. Other than that, there's nothing in an interface that appears to allow you to disable the inertial scrolling.

It wouldn't surprise me if the feature can't be disabled in the registry or requires custom non-microsoft drivers to disable it; the touchpad isn't an ELAN or Synaptics touchpad or whatever there is available right now, so the drivers for them will most likely not work correctly if at all.

Is there a way to disable this inertial scrolling, or at least change the touchpad's settings from the registry?


Edit: I have noticed that the Precision Touchpad behaves very similarly to a touchscreen. Scrolling with two fingers behaves as if you're swiping the screen, and zooming is done with a pinch gesture; Microsoft Edge does not let you zoom out to less than 100% zoom with the pinch gesture, just like a touchscreen. This most likely means that this inertial scrolling functionality is part of whatever code manages touchscreens in Windows 10.

2
  • You’re right. Increasing the touchscreen’s Friction does seem to make the touchpad spend less time sending extra scroll events. But I still can’t find a way to get rid of them entirely.
    – binki
    May 20, 2019 at 4:08
  • I'm having the same problem and still have not found a solution. I wish I could disable inertial scrolling. It seems to conflict with the scroll in the opposite direction and I have to wait for inertial scrolling to finish so I can move the opposite way.... Very annoying.
    – bombillazo
    Oct 25, 2020 at 2:54

1 Answer 1

0

This is probably fixed for you now as this was over 4 years ago, however I'd like to post the following update from Microsoft (KB4462933) which seems to have resolved the problem. If you are still experiencing this problem, try installing this update.

Addresses an issue that may cause an application that has a child window to stop processing mouse inputs. This issue occurs when a precision touchpad triggers a WM_MOUSEWHEEL event.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.