1

My system

  • MacBook Air
  • macOS 10.12.4
  • VirtualBox Version 5.1.30
  • vagrant Installed Version: 2.0.0
  • Joomla/box version '1.5.0'

Problems

Vagrant was unable to mount VirtualBox shared folders. This is usually because the filesystem "vboxsf" is not available. This filesystem is made available via the VirtualBox Guest Additions and kernel module.

Please verify that these guest additions are properly installed in the guest. This is not a bug in Vagrant and is usually caused by a faulty Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000 vagrant /vagrant

The error output from the command was:

/sbin/mount.vboxsf: mounting failed with the error: No such device

so back to ‘manually installing Guest additions?’

vboxadd.sh: Starting the VirtualBox Guest Additions.
Failed to set up service vboxadd, please check the log file
/var/log/VBoxGuestAdditions.log for details.
[/media/cdrom] $ more /var/log/vboxadd-install.log

/tmp/vbox.0/Makefile.include.header:112: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.

ls -l /lib/modules/4.2.0-27-generic/ gave me build -> /usr/src/linux-headers-4.2.0-27-generic

So build here is a broken symlink but where are linux-headers? When I try update headers get message already latest

2 November 2017. Upgraded Vbox to 5.1.30 r118389 (Qt5.6.3)

During installation error from mount -t vboxsf -o uid=1000,gid=1000 vagrant /vagrant

mount: unknown filesystem type 'vboxsf'
/tmp/vbox.0/Makefile.include.header:112: *** Error: unable to find the sources of your current Linux
kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.

Now /opt contains VBoxGuestAdditions-5.1.30/ So instal. /mnt already contains VBoxLinuxAdditions.run

Tried apt-get install build-essential module-assistant . got already newest

9 November new version of Joomla/box '1.4.4'. The latest is version '1.5.0'. Run `vagrant box update`

This system appears to have a version of the VirtualBox Guest Additions already installed. If it is part of the operating system and kept up-to-date,there is most likely no need to replace it. If it is not up-to-date, you should get a notification when you start the system. If you wish to replace it with this version, please do not continue with this installation now, but instead remove the current version first, following the instructions for the operating system.

/usr/src now contains  (as well as same joomla stuff) 
lrwxrwxrwx 1 root root 51 Nov 9 17:11 vboxguest-5.1.30 -> /opt/VBoxGuestAdditions-5.1.30/src/vboxguest-5.1.30/

drwxr-xr-x 12 root root     4096 Nov  9 17:44 virtualbox-4.3.36/  [but that’s not new version]

make sure that /lib/modules/$(uname -r)/build points to /usr/src/kernels/$(uname -r)  

but that does not exist

/lib/modules/4.2.0-27-generic/ contains
lrwxrwxrwx  1 root root      39 Jan 22  2016 build -> /usr/src/linux-headers-4.2.0-27-generic
drwxr-xr-x  2 root root    4096 Jan 22  2016 initrd/
drwxr-xr-x 12 root root    4096 Apr  8  2016 kernel/
-rw-r--r--  1 root root 1019813 Nov 10 11:08 modules.alias  . . .

Question on https://askubuntu.com/questions/889205/cant-solve-problem-with-virtual-box

because kernel headers were deleted from the repos because there is a new kernel release avaliable. So, s/he must update the whole system before installing the headers. OP replied ‘But sudo apt-get dist-upgrade says there's nothing to upgrade, same as upgrade.

sudo apt-get dist-upgrade

I got several errors.

Err http://ppa.launchpad.net/ondrej/php5-5.6/ubuntu/ trusty/main libedit2 amd64 3.1-20140620-2+deb.sury.org~trusty+5 403 Forbidden but that’s an http access error. Many files were installed/updated

Still same problems. Where is kernel source, if not in /usr/src ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.