6

I've upgraded VirtualBox to v5.2 and all my VMs are running extremely slow (operations that were taking seconds are taking minutes now). I've tried Windows 7 and Ubuntu guests so far with the same results. The host OS is Windows 7 x64, virtual machine files are on a SSD drive. It seems that performance is restricted by disk operations (host's disk indicator glows all the time).
Any ideas how to fix it?

2
  • How much free space is left on the SSD? If less than 25% then the SSD may simply choking.
    – LPChip
    Nov 11, 2017 at 22:03
  • 1
    @LPChip, SSD is fine, I checked it.
    – user626528
    Nov 11, 2017 at 22:11

3 Answers 3

2

In some cases, reinstalling the guest additions might help in these sort of situations

I have had to do this on some VMs after upgrading. No idea of the underlying causes, but it seemed to fix my issues (which did include slow performance.)

5
  • This might be a good idea, but it is a comment with a request for clarification and not an answer. Nov 11, 2017 at 23:48
  • I did reinstall guest additions, and no, this didn't solve the problem.
    – user626528
    Nov 11, 2017 at 23:50
  • ehh. Possible fix, and it seems a bit better to me after some rewording.
    – Journeyman Geek
    Nov 12, 2017 at 6:24
  • Yup, Guest Additions totally fixed it for me. I must be tired.
    – CAD bloke
    May 13, 2018 at 8:27
  • Switched from Virtual Box 5.x to a newer 6.0.22 version, and saw a large decrease in my Windows 10 VM performance (e.g. application freezes, slow context switching, etc.), to the point it was very frustrating to use. Re-installing the latest Guest Additions seemed to clear up the issue! Much appreciated!
    – Kevin
    Jun 23, 2020 at 2:25
1

The solution that worked for me: delete the SSD drive (where the VM files reside) via the Device Manager, reboot, refresh devices and reinstall SSD drivers, reboot.

-1

I have a virtual mac running on a PC and solved this problem, for me anyway:

  1. I went into the settings for the virtual machine
  2. Selected "network"
  3. Switched from "NAT" to "bridged adapter" This made the "Name:" field active.
  4. I changed the "Name" to "Broadcom 802.11ac Network Adapter", because that's what the PC is using right now.

Now, the virtual machine is as fast as the PC for networking

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.