0

I am running Outlook 2016 with an Office365 account. Its Local Failures folder has 750k messages, apparently totalling ~16GB. How can I delete them?

I can't actually view the messages: Outlook says the folder has no contents, despite the blue "2" next to it in the folder list. No idea why it says 2, because the details say the server version has 23, and the local one has over 750k.

I tried the obvious things, such as clicking 'Clear Offline Items' from the folder's details: this makes Outlook crash.

So I looked up some more, and installed mfcmapi and tried to empty the folder. I tried the following while Outlook was not running.

  • When in the screen "Delete Items and Subfolders" and checking no options, or just the option called 'Delete associated (hidden) items', then mfcmapi crashes.
  • If I select 'Hard Deletion', it throws an error.
  • If I select "Delete manually", it's (Not Responding) for minutes, and I decide to end the program after a while because to be honest I don't really want to manually delete almost a million messages.
  • If I try instead to Delete the whole folder, it throws that same error.

I have considered just removing and reinstalling the whole account, but the whole reason I'm trying to empty the Local Failures folder is because my Inbox refuses to sync with the server.

So anyone have another idea? Gratitude will be your reward!

If anyone asks, this is the error mfcmapi throws:

Error: 
Code: MAPI_E_UNKNOWN_FLAGS == 0x80040106
Function lpParentFolder->DeleteFolder( lpItemEID->cb, reinterpret_cast<LPENTRYID>(lpItemEID->lpb), lpProgress ? reinterpret_cast<ULONG_PTR>(m_hWnd) : NULL, lpProgress, ulFlags)
File Dialogs\HierarchyTable\MsgStoreDlg.cpp
Line 891
2
  • What about creating a new OST file and just walk away from the 750K bad sync failures? – I say Reinstate Monica Nov 12 '17 at 5:00
  • I wanted to avoid that at first because my local Inbox wasn't synced with the online mailbox... But it indeed seemed like the only option in the end, so I just chewed through refiling the mails of the past few months. Turning off 'cached mode' for good now... should have less issues in the future! – Sygmoral Nov 12 '17 at 23:03
0

I ended up removing and readding the account, effectively throwing away all local content (such as those Local Failures).

I was avoiding this solution because my local Inbox wasn't synced with the online one. So I moved the 'visible' mails in my local inbox to a new subfolder, because for some reason that one does manage to sync, and then removed and readded the account. Upon restarting (and making sure 'cached mode' is turned off), I just had to refile some mails of the past few months, and I'm up and running again now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.