2

Let me first explain the circumstances.

About a year ago, I started using Connectify to create a wifi hotspot from my Windows 8.1 Laptop. Then I bought a new computer with Windows 10, where I successfully used connectify as well (I actually bought an extra Wifi card to achieve this). Then, maybe half a year ago, I discovered the Windows 10 Wifi hotspot function. I wanted to try it, so I turned it on, but I didn't like it as much as the connectify hotspot (e.g. because it shuts itself down), so I wanted to use connectify again. There however I got the following error message: A Wi-Fi driver bug prevented the hotspot from starting. Please restart your computer and try again. I actually tried restarting, which didn't help, and even wrote to the support, which answered that my wireless adaper's driver doesn't work with a wifi hotspot (which doesn't make sense as it worked before). If you want to, I'll attach the log files or anything, but this actually isn't the problem. I then decided to use the built in Windows 10 hotspot, which worked pretty well for some time, until maybe a month ago.

If I click onto the mobile hotspot function

Mobile hotspot button

it's stuck on Connecting. Later it appears to be off again, but if I try to start it now, nothing happens. If I try to turn the mobile hotspot on over the Settings, it's always on the state off (even if I tried to start it over the menu you can see in the picture above). If I try to start it here, it's stuck on Applying settings, but if I restart the settings application, it's on the state Off again. Interesting is now, that the hotspot is actually turned on (I can detect it with my mobile phone), but I can't connect to it (it won't give me an IP address). If I select a static IP setting and assign my phone an IP address for myself (192.168.137.5 with the default Gateway 192.168.137.1, which seems to be my computer, which I know because of the message Windows 10 gave me and which you can see further below) it will connect, but tell me that I this network doesn't have an internet connection, which is correct.

If I go to Control Panel > Network and Internet > Network Connections, go to the properties of my Ethernet adapter, click on Sharing, both options (Allow other network users to connect through this computer's Internet connection and Allow other network users to control or disable the shared Internet connection) are turned on. However, the Home networking connection isn't selected. If I select something (e.g. my opened Wifi hotspot, which appears under the name of Local Area Connection* 11) and click OK, I receive the following message:

When Internet Connection Sharing is enabled, your LAN adapter will be set to use IP address 192.168.137.1. Your computer may lose connectivity with other computers on your network. If these other computers have static IP addresses, you should set them to obtain their IP addresses automatically. Are you sure that you want to enable Internet Connection Sharing?

When I click OK, the property window of my ethernet adapter stops responding for quite a long time, finally showing the message:

An error occurred while Internet Connection Sharing was being disabled. There are no more endpoints available from the endpoint mapper.

I searched for this message on Google but didn't get any results.

I'm using Windows 10 Pro, Version 1709, OS Build 16299.19. I couldn't find anything interesting in the event viewer of Windows and already tried reinstalling the driver of my Wifi card.

Does anybody have a solution to this, or is it just a bug of Windows 10?


EDIT: It's once again not working. After I applied Tiwaris solution it worked for a week or so but now I'm having a pretty similiar issue. Now however, if I try to turn it on over the settings, I get the helpful error message "We can't set up mobile hotspot." after some while. I really don't want to reset my firewall every week, so does anyone have an idea of how to solve this or is experiencing the same problem?

0

I had the same issue after upgrading my laptop to Windows 10 Fall Creators Update 1703. After a day of trys I have solved the problem by resetting the Windows Defender Firewall to the default settings. To do this open Settings -> Update and Security -> Windows Defender -> Open Windows Defender Security Center -> Firewall and Network Protection -> Restore Firewall default settings

  • Are you sure this works? And why did this answer get a downvote? – MetaColon Nov 16 '17 at 15:19
  • It works again, though it's not a very good solution, as it resetted all firewall configurations. – MetaColon Nov 29 '17 at 14:12
  • It's once again not working anymore - have a look on my question to get more details. – MetaColon Dec 7 '17 at 15:21
  • This didn't work for me. – Shafiq al-Shaar Mar 24 '18 at 9:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.