0

All our machines are connected to a VPN if they aren't on our local network, we've had no issues over the domain before.

So I get a laptop and try to connect it to the domain, do the same thing I do on all other machines (for laptops we set it as Local Network > VPN > Google DNS):

1- Configure the DNS:

It was a laptop, so I added the following, Local network (192.168.123.321), the VPN (10.1.2.3) and then the google DNS server (8.8.8.8).

2- Head over to the advanced settings and open Network ID:

"bar-technology.local":

The error was: "DNS name does not exist."
(error code 0x0000232B RCODE_NAME_ERROR)

The query was for the SRV record for _ldap._tcp.dc._msdcs.bar-technology.local

Common causes of this error include the following:

- The DNS SRV records required to locate an AD DC for the domain are not registered in DNS. These records are registered with a DNS server automatically when an AD DC is added to a domain. They are updated by the AD DC at set intervals. This computer is configured to use DNS servers with the following IP addresses:

8.8.8.8
10.1.2.3
192.168.123.321

- One or more of the following zones do not include delegation to its child zone:

bar-technology.local
local
. (the root zone)

I have never had the issue on a device with the domain before, and I cant figure out what's wrong? Its currently on the local network, so I tried running it like its on the local network, nothing.

So what do I do from here?

(

192.168.123.321 is the domain and DNS server

10.1.2.3 is the domain and DNS server on the VPN

8.8.8.8 is the google DNS server

bar-technology.local is the domain (I also tried the NetBIOS name BAR-TECHLOCAL)

)

  • 1
    I’m sure you realize that if you set a primary DNS server other than one of your DCs you’re going to have issues right? Google DNS servers respond negatively to the request. But the point is, they respond. Therefore your secondary and tertiary DNS servers will never be queried. It’s not possible to join a domain like this. I suspect you changed your VPN configuration which caused the system to use improper DNS servers when connected to VPN. In which case it could work like you want, but it’s your VPN connection settings that are bad, not your DNS settings. – Appleoddity Nov 12 '17 at 19:57
  • 1
    Either that or you reversed your DNS server addresses, making google DNS primary when it should not be. – Appleoddity Nov 12 '17 at 19:58
1

Make sure that the first server in your list knows about your AD domain. Since Windows supports per-interface DNS servers, make sure the VPN interface has higher priority than the LAN interface, and that bar-technology.local is among the configured per-interface domain suffixes.

When you configure multiple DNS resolver addresses on a single interface, they're only tried in case of temporary failure – either if a request timed out and failed to produce a reply at all, or if the reply was along the lines of "server failure".

"No such domain", however, is a permanent error and does not cause a retry. In fact the negative reply even gets cached by the OS.

In other words: If the system starts with your LAN server (192.168.x) and receives a reply "bar-technology.local doesn't exist", that's it – it will not keep trying other DNS servers; it will just accept that the domain doesn't exist.

(Using *.local for anything but mDNS is also a bad idea, but probably too late to rename…)

  • Imagine the VPN wasn't in the situation, and I just tried settings up a desktop on the local network but the issue still occurs, what would I do in that situation? (Thanks for your response and thanks in advance if you can answer this question : - ] ) – Brendan Jennings Nov 12 '17 at 20:12
  • The same thing. Do not mix nameservers which have different views of the DNS name space. – grawity Nov 12 '17 at 20:19
  • So what happens when I leave home with the laptop? No DNS servers = no domain resolving? – Brendan Jennings Nov 12 '17 at 21:14
  • Use DHCP so that it'll switch automatically... – grawity Nov 12 '17 at 21:35
  • Same issue. Gave the VPN priority, and I removed the google DNS server. – Brendan Jennings Nov 12 '17 at 22:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.