2

My Windows 10 laptop keeps adapting the brightness of my screen.

I did some research and found that the problem could be the Windows' "adaptive Brightness" feature. I disabled it but kept having the same issue.

So, I did some more research and found that the Intel's "Display Power Saving Technology" could be the issue. So, I disabled it, but I keep having the same problem.

Does anyone know what else can be doing this brightness adaptation. It is starting to become very frustrating.

6

Changing power plan settings did not work, you need to type ''run'' then type ''services.msc''

Search in the list for ''sensor monitoring service'' right click on it, properties and disable the service, hit apply.

Navigate to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Brighten Movie and change ProcAmpBrightness to 0

also navigate to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Darken Movie and change ProcAmpBrightness to 0

Restart.

1
  • Well, I'm using the notebook for a while now since I disabled sensor monitoring service and apparently it worked. Thank you very much. – user2699664 Nov 14 '17 at 15:15
1

I've looked around the web and there appear to be several possible causes and solutions to this problem depending on your Windows version and hardware. Here's a compilation of how to turn off adaptive brightness.

  1. Go to Power Options > Display > Enable Adaptive Brightness > Set it to Off in both places

enter image description here

  1. Go to AMD Catalyst Control Center > Power > PowerPlay > Uncheck the "Enable Vari-Bright" box

enter image description here

  1. Go to the Intel Media and Graphics Control Panel > Power > Disable Intel Power Saving Technology

enter image description here

  1. Go to Services > Disable the Adapative Brightness service

enter image description here

  1. In regedit:

    Go to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Brighten Movie and change ProcAmpBrightness to 0

    Go to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Darken Movie and change ProcAmpBrightness to 0

1
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Feb 5 '18 at 6:25
0

I had the exact same problem and nothing was working but i figured it out, this is what i did: go to power options>edit plan setting> change advanced power setting>ATI graphics power setting>ati power play setting. And then on battery choose maximize performance instead of maximize battery life.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.