0

I am trying to make a static arp entry for my gateway 192.168.2.1. I am using Windows 7 Ultimate 64 bit and at first I tried:

arp -s 192.168.2.1 00-11-22-33-44-55

But I was getting a permission denied error so I started to look around and found out that on Windows 7 64 bit I need to use netsh. I found some commands on some other posts to try but the add neighrbors command responds with

Invalid neighbor parameter (00:11:22:33:44:55).

every time that I try.

I first used this command which seems to work:

netsh interface ipv4 delete neighbors

And then this is the command that gets an error

netsh interface ipv4 add neighbors "Local Area Connection" "192.168.2.1" "00:11:22:33:44:55"

I also tried without the quotes and got the same response with this.

netsh interface ipv4 add neighbors "Local Area Connection" 192.168.2.1 00:11:22:33:44:55

It doesn't make sense to me because if I run:

netsh interface ipv4 delete neighbors "Local Area Connection" "192.168.2.1" "00:11:22:33:44:55"

It works just fine and gives me the Ok response so I am not sure what is going on. Does anyone have any suggestions? I am also running cmd as admin and I do know my correct gateway mac address.

0

I got it figured out. Turns out that I was using the wrong mac.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.