2

When I try to install Windows 10 on a VM, this appears:

enter image description here

Network boot from Intel E1000
Copyright (C) 2003-2014 VMware, Inc.
Copyright (C) 1997-2000 Intel Corporation

CLIENT MAC ADDR: 00 0C 29 EC 19 17  GUID: 564D036B-A131-62B4-9CG4-4BAAEEEC1917
PXE-E53: No boot filename received

PXE-M0F: Exiting Intel PXE ROM.
Operating System not found

or

Network boot from Intel E1000... (etc.)

Looks like PXE...

I recreated the VM, and it gave me an EFI boot message.

Attempting to start up from:
-> EFI VMWare Hard Drive
-> EFI Network Boot...
->...
  • 2
    Images are not reable for everyone. Please consider adding the actual text for those of us with screenreaders etc. It also makes it much easier to search for. As to the second error 'an EFI boot message' is rather vague. Please edit the post and add the actual error. And mention if you are doing an EFI boot on a GPT formatted vistual disk or any other boot. – Hennes Nov 14 '17 at 15:50
  • Thanks for adding an image, Alfabravo I don't have enough rep to do it :) – Ray Wu Nov 14 '17 at 16:03
  • Have you correctly configured the CD Drive in your VM? e.g. it should be either the physical drive if you are inserting a physical DVD disk or location of the DVD image .iso for example. – rajeev Nov 14 '17 at 16:07
  • It's the ISO, positive. – Ray Wu Nov 14 '17 at 18:32
  • In the boot text I do nto even see it attempting to access an iso or a physical DVD player. It there more text above it where it tries to do so? If not, go to the VMs firmware (aka the fake BIOS) and make sure that it does see its harddrive, that a CD is visible and that network boot is not set as the first option). – Hennes Aug 28 '18 at 4:53
6

I had the same issue. My solution was to recreate the VM, select Advanced when installing, and choose BIOS instead of UEFI.

  • 1
    For VM Fusion 15 I had to un-check "easy install" and this worked. – Nick M Jan 3 at 3:07
  • @Sam1370 There is no possibility to change this setting AFTER the creation of a VM? – PeterCo Mar 15 at 11:27
  • 1
    @PeterCo Honestly I don't know, you could try. I am literally a complete beginner to VMWare and I found this question in search of help. A few minutes later I found the answer and decided to post it. – Sam1370 Mar 25 at 0:44
1

I had the same issue today and my fix was going to the VM configuration and under OS, changing Windows 7 to Windows 7 x64.

Then it booted into Windows 7 Installer ISO in UEFI mode (with secure boot unticked).

  • IIRC win7 UEFI is x64 only, so setting it to ancient 32 bit mode would indeed cause problems. – Hennes Aug 28 '18 at 4:51
0

As we see in the screenshot, your VM is attempting PXE boot and failing. What is likely happening is that you're not able to connect to the VM quickly enough to respond to the Press any key to boot into Windows Installer screen.

To fix this, set the boot delay to 6 seconds or higher to give you time to click this. Browse to the folder containing our VM and open the .vmx file in Notepad or your editor of choice. Then, scroll to the bottom and add this line to the config file.

bios.bootDelay = "6000"

This should provide enough time to start the VM, then hit ESC to choose your boot device. Pick the Windows 10 ISO and then hit a button to when you see the prompt for Press any key to boot into Windows installer.

If this still doesn't work, then ensure that you set the disk image as the first boot device.

  • The 6000 means 6 seconds? (I'm a programmer, I'm used to these things) – Ray Wu Nov 14 '17 at 16:02
  • Yes, it's an amount of time in milliseconds. – FoxDeploy Nov 14 '17 at 16:27
  • This shows i67.tinypic.com/4kdgx.png – Ray Wu Nov 14 '17 at 18:36
  • Hit ESC to choose the boot device and then pick the Windows 10 install .wim file you mounted. – FoxDeploy Nov 15 '17 at 14:12
  • 1
    I chose dvd drive and nothing happened but it saying "Operating System not found" xD why – Ray Wu Nov 15 '17 at 22:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.