21

So at work, my Firefox got automatically updated to 57.0 (Quantum) since I have automatic updates enabled.

Turns out that a lot of add-ons don't work anymore with 57.0, e.g. the session manager and the tab group add-on which I use extensively. It seems that I lost all but the current tab group which I'm not very happy about...

Now, at home I use the same add-ons and I'd like to prevent losing my tab groups so I'm looking for a way to disable automatic updates (which are enabled) before I start Firefox so that I get a chance to save/export my tab groups and find a solution that will work with 57.0 before actually updating to 57.0.

How can I do that?

  • 2
    You should not follow any answer that advises you to disable automatic updates: that's bad advice that can open your computer up to being infected with malware or "hacked." – Kaypro II Dec 29 '17 at 6:32

10 Answers 10

11
+150

The solution to disable automatic updates without running Firefox is as follows (OS is Windows):

  • Edit the file prefs.js, located in %APPDATA%\Mozilla\Firefox\Profiles\xyz.default\ which usually translates to C:\Users\username\AppData\Roaming\Mozilla\Firefox\Profiles\xyz.default\ (Note: username and xyz will vary)
  • Make sure the line user_pref("app.update.enabled", false); is present in the file; if it isn't, add it or modify it. Ignore the warning that this file should not be edited
  • Save and close the file
  • Start and use Firefox without having to worry about automatic updates
  • Optional: Note the button "Check for updates" in the "About Firefox" dialog box. Of course, DO NOT click it until you are prepared and ready to receive the update
  • 2
    Man this browser is looking more and more like google chrome every day, why did they take the automatic updates option out of the GUI. It started with the forced addons signing, now they're limiting what the addons can do and removing the update button from the GUI. What's next, Windows 10 style forced updates? – thebunnyrules Dec 11 '17 at 6:19
  • 2
    The above answer is bad advice. By disabling automatic updates, you also disable security patches. In simplistic terms, if you do this it means a website could hack your system and install malware because you never installed the patch to prevent that. – Kaypro II Dec 29 '17 at 6:28
  • 2
    The correct advice is to downgrade to Firefox 52 ESR release, which supports XUL extensions will still receive security patches until the summer of 2018 (if I read the graphic correctly). After that, you need to abandon your XUL extensions, but hopefully they'll have been updated by then. – Kaypro II Dec 29 '17 at 6:29
  • 4
    The question was specific. The user was currently using Firefox 56, they wanted to prevent the automatic upgrade to Firefox 57, this accomplishes that. The answer does not indicate you shouldn't update Firefox, this answers allows you to choose when that happens, which is great for those who use an extension that cannot be replaced. – Ramhound Jan 19 '18 at 2:03
6

An alternative solution to blocking all updates, is to move to a fork of Firefox which will keep the XUL add-on format, now called "Legacy" by Firefox, while still installing security updates.

Two Firefox forks that keep the legacy add-ons are :

I have tried Pale Moon, and it very nicely imported all my add-ons and profile data. Screen layout was lost and so some small customizations were still required, but in general this is now an exact duplicate of my Firefox version 56, except that it still does security updates.

  • Do the security updates originate from Waterfox, or is there a Mozilla tie-in where Mozilla security updates for Firefox are retrieved and applied? Also, is there an advantage of this over going to Firefox ESR (other than ESR will eventually get the new code base, also)? – fixer1234 Nov 26 '17 at 20:39
  • 1
    @fixer1234: Both are FF forks, so most (if not all) security updates originate from Mozilla. FF ESR has problems with some addons being unable to save their settings, example LastPass. Also, the ESR version, while based on FF56, is strangely numbered version 52, so some addons refuse to work, requiring at least FF55. In addition, ESR will elapse in several months, while both Waterfox and Pale Moon intend to support XUL add-ons longer, if not forever. It's quite frustrating that the XUL code is still in FF57, only it's just disabled. – harrymc Nov 26 '17 at 21:18
  • 1
    @fixer1234: Waterfox is much closer to the current FF than Pale Moon which forked-off several years ago. Pale Moon has its own addons store (fewer), while Waterfox uses Mozilla. – harrymc Nov 26 '17 at 21:36
  • Good information in your comments. Consider adding it to the answer. :-) – fixer1234 Nov 26 '17 at 22:21
  • @harrymc - Are you positive that 52 ESR is based on Firefox 56. The chart seems to indicate 52.5.3 is based on FireFox 52/56 the chart isn't actually clear. Feel free to hint me up in chat though. – Ramhound Jan 19 '18 at 2:09
1

Better off changing user_pref("app.update.mode", 1) to 2

WHY

app.update.mode uses an integer value (default 1) to decide the "behaviour" of updating... if you modify this value you are not:

  1. altering the developers code by injecting your own custom code or
  2. stopping upgrades altogether

the following is from https://wiki.mozilla.org/Software_Update:Testing

INTEGER - app.update.mode Default: 1 defines the policy by which background downloads are done, and the amount of user prompting that is required: 0 - download all update types (major/minor) without user intervention, regardless of incompatible extensions installed (they should just be disabled after the update restart) 1 - download all update types (major/minor) only if there are no incompatibilities with enabled extensions, prompt with UI otherwise. 2 - download minor updates only, prompt for major updates, regardless of whether or not all enabled extensions are compatible.

an upgrade to quantum is definitely a major upgrade...

0

Open your Firefox preferences and use the built-in search bar (present since version 56) to look for "update", then check the option to never update automatically.

That's not recommended though, since you won't get security updates. You can use the latest long-term support release instead: https://www.mozilla.org/firefox/organizations/

  • 1
    Well I don't want to start Firefox, as I have written in my question, because when I do I will most likely get the update immediately. – Nassbirne Nov 14 '17 at 20:40
  • It was launched today. If you haven't opened it yet today, it will start downloading it to upgrade it only after you open it a second time, so you can change the setting before that happens. If you are afraid it has already downloaded it, look up "prefs.js disable update" on Google to learn how to find that file and what to change. – Firefox57 user Nov 14 '17 at 20:44
  • Yes, I found the prefs.js method before, but the parameter they mentioned is actually missing in my file so I didn't try it. – Nassbirne Nov 14 '17 at 20:52
  • 1
    prefs.js only lists the parameters that have been modified from the default values. You can add the option you've found to it. It will be the same as adding it from about:config . – Firefox57 user Nov 14 '17 at 21:12
  • @Nassbirne - So how about submitting an answer with specifics on what you did, assuming what you did, prevent an automatic update to Firefox 57 Because using the ESR version of Firefox isn't an option for some people nor is the other answer helpful due to it being a link-only answer. – Ramhound Nov 14 '17 at 21:55
0

In Windows 7 I went to AppData\Local\Mozilla\update. In the update folder, delete whatever is there. Also never check your current version in “Help about Firefox” as this will get you back on the the update treadmill again.

  • On Windows 10 this path is named "AppData\Local\Mozilla\updates" with an s at the end. After reverting to 56, you can go into options to uncheck auto-update, but it will have already started re-downloading quantum, and this auto-download is not aborted even if FF is closed and reopened, so this step is needed to finally abort the Quantum reinstall. – Dale Mahalko Jan 1 '18 at 10:50
0

What helped in my case, beside of disabling update in configuration, was just renaming the updater.exe executable in Firefox installation directory.

In case of big errors you can just write simple application that does nothing but restarts Firefox and closes itself, then put it in Firefox directory as updater.exe.

Uninstalling "Mozilla Maintenance Service" and/or also renaming its binary can also help.

  • 1
    I experienced the same Firefox bug. And I did a similar trick: I replaced C:\Users\USER_NAME\AppData\Local\Mozilla\updates directory with an ordinary file so that firefox could not download the updates. – Alexey Mar 22 '18 at 8:28
0

As other users have pointed out, Firefox used to have an about:config option to disable this (called app.update.enabled I think), but the devs no longer trust you so they changed this so auto-updates are hard-coded on. However, if you look at some of the other app.update.* preferences, there is a remaining option the devs overlooked.

They left the app.update.interval option, which specifies the time between auto-updates in seconds. If you set it to some arbitrarily large number, like 432000000, you could make Firefox wait for years, effectively disabling updates. This should be easier and more reliable than having to manually edit some Javascript file which will probably just be reset after the next system package update.

Presumably, the devs will alter or remove this option as well, so the better long term solution is probably to abandon Firefox altogether and use a browser that respects your privacy and doesn't force you to auto-update against your will.

  • Interesting approach. Have you actually tested it to verify that it works? – fixer1234 Jun 25 at 20:20
-1

I believe a method to prevent upgrade when launching your firefox is to disconnect your computer both from wired and wireless connection before launching and delete upgrade folder, then you can change the config.

Also, according to report, Firefox would check for update when you lick the about firefox page even when automatic update is off so that should be avoided.

See also https://support.mozilla.org/zh-CN/questions/1041197

Edit: For your work computer, I am not sure have the firefox update cleared old addon data yet or simply disabled them, if data for those addon are still there then it will be possible that they could be migrated to the ESR version (extended support)that was based on previous firefox and thus legacy extension would still work. See https://www.ghacks.net/2017/11/14/how-to-move-firefox-legacy-extensions-to-another-browser/ for how to migrate addon data to the ESR version

-1

Problem: Firefox setting to "do not check for updates" still updating.

Turns out my Kaspersky Total Security software was set to check and update apps automatically. Every few days, it would check and update firefox. After turning auto updater to off -- voila! no problems.

-2

I made the mistake of letting Firefox update itself to the latest version, and so I lost all my valuable extensions. After trying it for a while, it was obvious to me that I had lost a lot of functionality, so I decided to revert back to version 56.0.2 (latest stable version).

So, if somebody like me, wants to revert back to v.56 without uninstalling and reinstalling a fresh copy, and then prevent automatic updates to v.57, please continue reading.

After looking around to find the best solution to revert back, it seems that the old version can be safely installed on top of the new without losing any settings or add-ons (based on this post).

So, the steps followed were (am using Windows 10 64bit):

  1. Made a back-up of my profile folder based on this just in case

  2. Downloaded the 64 bit version from filehippo: Firefox v56.0.2 64bit (the 32 bit version is here filehippo: Firefox v56.0.2 32bit) and reinstalled v.56 direct on top of version 57 without previously uninstalling it.

  3. Before restarting, I disabled my internet connection (just to prevent Firefox from self-upgrading) and then after launching Firefox 56, I changed the update option as follows
    Tools --> Options --> General --> scroll down to "Firefox Updates" and check "Never check for updates (not recommended)" - Other options proposed in this topic might work as well.

  4. Shut down and Restart computer (this time with internet connection enabled as usual) and launched Firefox 56, which had all the settings, extensions and add-ons intact as before upgrading.

I am using v.56.0.2 without problems for a week now (of course I don't touch "check for updates" in Help --> About Firefox). In case that for any reason, Firefox upgrades itself again to v57, you can repeat the above procedure. Happened to me with my laptop.

Although I know that I will be left without updates for a while, my decision is to wait until all my critical add-ons and extensions are upgraded for v.57 (and all the "child diseases" of the new version are eliminated).

protected by Community Jan 17 '18 at 7:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.