0

I have been up since the morning trying to figure this out so I'm going to have to just throw this question up here and hope someone can help me with this problem...

After downloading the update, the updater then switches to "installing updates...", it stays at 0% then throws this error:

Security Update for SQL Server 2016 Service Pack 1 GDR (KB4019089) - Error 0x80070643

I have googled this problem, there are very little results which I have tried over and over but no matter what I always end up stuck on this update and this same exact error each time.

Only thing I can think of is a manual installation of this update but I'm not sure which one it is or how to do it. I tried the manual installation and still get "Failed" at the very last window of the wizard. Maybe I was doing it wrong. It has a lot of options and tick boxes which I just don't understand at this time.

  • "but I'm not sure which one it is or how to do it. " - The update is KB4019089 and it is located in the same location every KB update is located at the Microsoft®Update Catalog but you should verify the update is even applicable to your SQL Server 2016 installation. – Ramhound Nov 14 '17 at 22:15
  • @ramhound what do you mean by verify the update is applicable? This is the update that is automatically being assigned to me through the windows service. – Daniel Nov 14 '17 at 22:27
  • @ramhound I will format it as soon as I know what I'm doing here. How do I verify my file versions? Also, what information do you need exactly once I reformulate the question...? I apologize if I come across as too unknowledgeable here but, like I said, this has me completely stumped as of right now. – Daniel Nov 14 '17 at 22:28
  • View the properties of the file. "lso, what information do you need exactly once I reformulate the question.." - The versions of the actual dll files, don't worry about the text documents, for obvious reasons. – Ramhound Nov 14 '17 at 22:30
-1

You can try Resetting Windows Update following the official guide.

If you still have problems, try to install the update manually after that.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.