0

The Ubuntu version is 17.10 (Artful Aardvark), completely up to date. It was originally installed on a USB 3.0 key, was running on a x64 architecture system, and connected to an older (2.0) USB port. It was running perfectly fine.

Today I tried to boot the USB key on another system (same architecture, though). I've tried both 2.0 and 3.0 ports and got the same issues as I'll describe next.

Boot from BIOS seems fine, the GRUB menu and countdown are working, it starts booting with no issues, but at some point it stops, showing errors like:

  • xhci_hcd 0000:00:10.0: Timeout waiting for setup device command
  • usb 6-1: device not accepting address 2, error -62
  • usb6-port1: unable to enumerate USB device

Eventually, it ends up reporting gave up waiting for root device, with Alert! UUID=<usb key uuid> does not exist. Dropping to a shell!!

At that point (on initramfs console), if I just remove the USB key and plug it again, the USB key is recognized and then, after entering exit in the console, Ubuntu starts normally.

Moreover, I tried the same on reboot, while getting the mentioned errors: just removed the USB key and plugged it back, and Ubuntu starts booting up (no initramfs this time).

So, it seems after moving the USB key to the new system, there something about USB ports that the original installation is not considering at boot time.

Any suggestions?

Update: I tried another approach, just to check if the USB version was an issue: I cloned the USB key 3.0 to a 2.0, and it worked perfectly on the new system.

  • If the USB 2 stick worked, then write up an answer, and give it the checkmark so future readers can easily see the answer. I've found that you can't always boot from USB 3 ports. – Christopher Hostage Nov 14 '17 at 23:39
  • Yes, cloning the usb3.0 stick to a usb2.0 and booting the new system from the later, worked perfectly. But it does not answer my question. Please, see the scenario I described regarding specifically re-plugging the usb3.0 while on initramfs console. From that point, the problematic stick still works, so there could be something missing in the boot process. – Dario Nov 14 '17 at 23:46
  • @ChristopherHostage I will add the answer if there are no more comments / answers trying to explain what can cause the usb3.0 / boot process issues. – Dario Nov 14 '17 at 23:48
  • You should submit the answer regardless because your answer was the solution to your problem. Booting from a USB 3 device even connected to a USB 2 port can be problems for older hardware – Ramhound Nov 15 '17 at 0:29
  • @Ramhound ok, I'll add the answer as you both suggested. – Dario Nov 15 '17 at 0:32
0

Booting from the USB stick v3.0 was the issue: cloning the Ubuntu installation from the USB 3.0 to an older USB 2.0 solved the boot problem.

It is worth to mention that the original working scenario involved an older PC (with only USB <= 2.0 ports), and a USB stick 3.0 with Ubuntu installed on it. The new (and current, given this answer) working system involves newer hardware with both legacy USB and 3.0 ports. The cloned OS is now running on a USB 2.0 stick and USB 2.0 port.

This answer is also valid for the same solution applied to the USB 2.0 stick, in a 3.0 port.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.