I just updated Firefox to Firefox Quantum 57.0 64 bits and Gmail doesn't work, it shows this error:

Gmail requires cookies to be enabled

Cookies seem to be disabled in your browser. Gmail requires cookies to be enabled in order to operate.

To use Gmail, enable cookies by changing your browser's Preferences or Options. If you have a third-party cookie manager, you will have to configure it to allow cookies from Gmail.

After enabling cookies, try again.

But this really doesn't make any sense, because cookie configuration is the same as before, it worked before the update. Other Google services as Calendar or Hangouts work fine.

Things I've tried:

  1. Cleaning cookies.
  2. Clearing Firefox cache.
  3. Try Private Window, same problem.
  4. Try Edge and Chrome, both work.
  5. Check extensions, they are all disabled because they are not compatible with the new version, except Adblock Plus and Privacy Badger (but I disabled them and the problem persisted).

UPDATE: Ok, I just noticed something funny is happening with cookies, because Reddit keeps showing the cookie alert even after I agree.

Any ideas?


  • 1
    Try creating a new profile how to do this. Of course my firefox quantum worked out of the box w/o trouble
    – Kitet
    Nov 15, 2017 at 10:56
  • That worked, Gmail opens properly in a new profile. And now I'm back at the default profile and it also works, pretty weird. Thanks!
    – JoePerkins
    Nov 15, 2017 at 11:09
  • There is still the Reddit cookies issue, and I guess other sites will behave that way too. Maybe I should do a clean install :/
    – JoePerkins
    Nov 15, 2017 at 11:13
  • No repro here...
    – DavidPostill
    Nov 15, 2017 at 15:47

2 Answers 2


I don't know why @citizenserous is being downvoted. His answer is right; though he didn't give much details (and as I don't have enough reputation to comment on his answer, I'll expand on his).

Here's a detailed walk-through:

  1. Open the 'side menu', 'navigation drawer' or 'hamburger button' ()
  2. Click 'Preferences'
  3. Search for 'cookies'
  4. In the History section, where it says 'Firefox will', switch from 'Remember history' to 'Use custom settings for history'
  5. Click 'Exceptions'
  6. Type in 'https://mail.google.com/' (without the quotes) and click 'Allow'
  7. Click 'Save changes'
  8. You can restore the 'Firefox will' 'Remember history' option.

Update: After testing some more, I now believe the proper answer is to Refresh Firefox. This is because the answer I originally gave didn't fully fix all the hiccups I was experiencing in Gmail.

  • After opening Gmail with a new profile and going back to the previous one it got fixed, so I couldn't really try this. I did try with Reddit cookies and it fixed it, so it's probably the right answer. The problem was affecting a ton of sites, so the best solution for me is either refreshing Firefox or switching permanently to a new profile, so I'll accept this as the answer. I guess there was some sort of weird conflict with my Firefox configuration, the profile folder was huge after many years of use. Thanks! :)
    – JoePerkins
    Nov 16, 2017 at 21:06

put https://mail.google.com/ as a exception in the cookie list, I had the same issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .