0

I have been trying to remove a locked folder from my Mac. I am logged in as admin.

When I try to delete it from Finder, it says

The operation can’t be completed because the item “X” is locked.

I have tried deleting it from the terminal by booting into recovery mode.

I have started my Mac using a Linux Live CD, mounted the Mac partition and tried removing it. Still no success.

I have also used:

chmod ugo+w .

chattr -i -a .

Also tried booting into single user mode to remove the folder. No luck.

  • 1
    If you have admin privileges, you can follow these steps to unlock the folder. It may ask you for an admin password. – Bandersnatch Nov 15 '17 at 18:08
0
  1. Select the folder you want unlock from the Finder of the Mac

  2. Go to the File menu and choose “Get Info” (or hit Command+i)

  3. Look under ‘General’ and click the ‘Locked’ checkbox so that it’s unselected, this will unlock the folder

  • When I try to do that the checkbox is checked and the text 'Locked' is grayed out. This is after unlocking the Get Info panel. – uiwarrior Nov 16 '17 at 16:13

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.