0

I'm asking this question because: 1. I'm desperated, 2. I couldn't find any other answer resolving my problem, 3. All my attempts to fix it by myself failed.

I have got an external HDD 3,5" that is no longer recognized by the system(win7). One day I moved most of my laptop's data to it prior to system reinstall. The backing up process went well. The next day when I tried to copy the data back to the laptop, the system could not recognize the file system anymore (assuming it is RAW) and asked me to format the disk. Other computers I tried the drive with also show the same problem.

I didn't delete anything or formated the disk. My aim is to recover the entire folder structure, not just files.

The first step was to create a full disk image using Macrium Reflect. It took some time but it worked. mounting... mounted After mounting the image, I could observe the same behavior(RAW / needs to be formated before usage). mount result 1

I then tried to recover the ntfs partition using testdisk but don't quite know how to proceed.
here are the steps I have completed so far with testdisk

  1. choose the disk
  2. partition type intel - initially 'none' was preselected
  3. choose operation - analyse
  4. quick search results result 1 continue result 2 5.Deep search mode result 1 result 2

I'm stuck here, tried before to change the partition type to only logical(because it is not bootable, although there was an Ubuntu running on this drive shortly long time ago - thus the two ext4 partitions).

Does anyone know what steps should I do next toin be able to use this partition again? Or maybe there are some other tools I sould go for?

The testdisk halts on the last screen(deepsearch result 2). It takes hours to rescan it so I wait for your answer before I go any further.

Any help will be trully appreciated. There are thousands of pictures of my family, especially my daughter (over 10 years of detailed documentation ;((((( )

2
  • before you do anything, check the smart stats on the disk, to determine if it is mechanically healthy. making that determination up front helps you determine what the next step should be. – Frank Thomas Nov 15 '17 at 19:57
  • although I was able to recover the data using the tool from the approved answer, I will try this approach as I want to find the reason for the abnormal behavior. Update follows... – mark Nov 15 '17 at 21:48
-1

I think you will need some sort of data recovery tool. I know StackOverflow purpose isn't about software advising, but i have to recommend R-Studio. Have used it a couple of times with good results. Sometimes you can even see the folder structure and retrieve those files.

3
  • Please read How do I recommend software in my answers? and edit your answer to follow the outline. – Kamil Maciorowski Nov 15 '17 at 19:26
  • I have tried with the demo version of this software in the first place. It was able to discover the ntfs partition and gave me the option to navigate through the folder structure as well as recover the data after purchasing the licence(without the licence it is limited to 256 kB). the process is still ongoing - 10.000 out of 195.000 files, 7 more hours to go. I usually try to solve problems with free tools but this time, after three week of trial and fail I was simply exhausted. – mark Nov 15 '17 at 20:57
  • @mark or you could have used RecuperaBit as already mentioned in several answers (which you said do not exist, but they do). – Andrea Lazzarotto Nov 17 '17 at 9:55
1

It's possible the enclosure circuitry has failed, so I'd suggest taking it apart and extracting the HD/SSD. You can try attaching it internally to a desktop computer temporarily to see if the drive is visible that way.

There's also the long-shot of replacing the controller board on the drive with an exact same model drive, since that could be what's bad. Sometimes, though, the board is matched to the physical drive due to latency calibration.

If this fails, you're looking at taking it to a professional for recovery, and they may suggest sending it to a forensic recovery company.

I've been able to recover some hard drives, but it was few and far between. I don't even remember the software I used or if it's still available. Maybe someone else can answer with that info.

Good luck!

3
  • since I was able to create an image of that disk on a brand new external drive, I'm not quite sure if it could be any hardware/circuit related problem. Also, a friend of mine did what you just wrote - he disassembled the hdd form its enclosure and connected it using a typical docking station - with no luck. It took him ages to create an image and it was stuck at approx. 180 GB out of 750. With the macrium reflect I was able to create a complete image (took about 7 hours) – mark Nov 15 '17 at 19:27
  • That... sounds bad, really bad. So, you'll just have to try the controller board and go from there. Sorry for your troubles! – computercarguy Nov 15 '17 at 19:36
  • its not abnormal for ddrescue to take weeks on a seriously messed up disk. – Frank Thomas Nov 15 '17 at 19:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.