1

On my Windows 10 Home pc I have two users, both without password. To disable the automatic login feature, the usual hack was to alter the registry and set Enabled to 1 in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch. See for instance here: How to prevent automatic login of the last user in Windows 10?

This has been working for some time, but after the recent Fall Update, it no longer works, and the last user is automatically logged on again. Even when logging off before powering off the pc.

Does anyone know of a (new) workaround, preferably not involving passwords?

  • Have you checked that the registry hack you made was not simply changed or removed by the update? – techturtle Nov 16 '17 at 16:58
  • Yes. Actually the value was reset by Windoes every time, but I run a task at logoff that sets the value to 1 again. I just confirmed it's still 1. – Berend Nov 16 '17 at 17:03
  • I feel for you. I just gave up and started using passwords. If Microsoft doesn't implement that simple switch, and (perhaps inadvertently) breaks the workarounds, there isn't much that I can do. I mainly use Linux, which I can bend to my will to a much greater extent. I can't be bothered to play catch with Microsoft. – hayalci Dec 26 '17 at 20:41
0

This blog posts suggests disabling "Use my sign-in info to automatically finish setting up my device after an update or restart" in user account options.

https://keegansdiet.wordpress.com/2017/11/09/login_auto-dis/

Possibly this would need to be done for all user accounts.

  • Sorry, but that's not it. That setting was already disabled. – Berend Dec 31 '17 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.