I am constantly getting "web login required" when accessing Gmail using POP from the email application. I know what should be causing it but I am unable to figure out why it won't go away. Here is what I tried:

But it still persistently shows "web login required". Did I miss anything else? Is there a way to "reset" the account so the web login required goes away?

  • 1
    Have you tried creating an app-specific password? That way your email app can use a one-time use password and you can keep the more secure password and 2-factor settings applied to your account. Nov 16, 2017 at 17:29
  • @music2myear I did, enabled 2-step verification and created app-specific password (and replaced regular password in email app, with the app-specific password) and the only result was again the very same "web login required". Nuts!
    – Coder12345
    Nov 16, 2017 at 19:33
  • 1
    What email application? Your question is still lacking relevant information. Please edit it to improve the question and our ability to answer it. Nov 16, 2017 at 19:53
  • It is not relevant for the question but it is Outlook Express. The question applies to any POP client as POP is standardized protocol.
    – Coder12345
    Nov 18, 2017 at 0:27
  • Same problem with Thunderbird.
    – zezollo
    Jan 30, 2018 at 11:37

3 Answers 3


I just had the same problem and ultimately it was fixed by the Less secure apps setting. Which I know you already tried to set. It didn't take for me either when I set it via this link:


When I visited this page, scrolled to the bottom, it was still disabled, and enabling it there corrected the issue.


Also, make sure you use your full email address as the username.

  • Just an added step to the 'less secure apps' setting: if the error message POP3 says "Web login required", just log out of the account and log in again.
    – Ramses
    Feb 6, 2019 at 2:23

Try deleting temporary Internet files under Tools/Delete Browsing History in Internet Explorer, especially if you've just changed the ISP you're using.


The solution for me was also 'Less secure apps setting'. It is odd, but I had to turn it off and on again and it is working now...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.