0

I did the recent update for Windows 10 and it restarted my computer. Now I can't use USB.

The computer is an ASUS Essentio M11BB. The operating system is Windows 10 Home.

https://www.asus.com/us/Tower-PCs/M11BB/HelpDesk_Download/

It originally came with Windows 8 or Windows 7.

There are no USB drivers for Windows 10, only for Windows 7, so I tried to install that. Still didn't work. Tried to uninstall and hoped that would reset it. Still no luck.

Tried installing the chipset drivers for Windows 8.1 and utilities drivers for Windows 10. Didn't help at all.

I've also tried safe mode and tried to revert to an earlier mount before this last update. Didn't help either.

Currently trying to continue Windows Update in the vague hopes that will fix something but I'm out of any other routes I can take.

Are there any other options left for me?

  • How were you installing / uninstalling if your mouse and keyboard didn't work? What specific devices didn't work? – Christopher Hostage Mar 8 '18 at 22:06
0

If the official website does not have the relevant USB and motherboard driver, this usually means that we can't use it because it doesn't support. If you use a low version of the driver (Win7 or Win8) is also not compatible, try using some third party software like Driver Easy or something else. Maybe it could find compatible driver for Windows 10.

0

There was a problem with an update from february, kb4090913 should fix that

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.