1

Since I updated to High Sierra (directly to 10.13.1) I can't connect my iMacs and MacBook any more by AFP protocol, so I tried SMB.

open 'smb://user:password@S/Share' :: works, but shows Finder on the screen.

Another problem is that I can't choose the mount point's name. I work from JAVA applications and thus should work from the command line:

mkdir /Users/user/Volumes/Share/

/sbin/mount -t smbfs //user:password@S/F /Users/user/Volumes/Share/

But this gives:

mount_smbfs: server rejected the connection: Authentication error

What did I do wrong or forgot about? Thanks in advance. ;JOOP!

0

The following command can run in High Sierra (tested in 10.13.6).

mount_smbfs -f 0755 -d 0755 smb://username:passwd@SAMBA_SERVER/PATH /your_local_pre_exist_folder/

Note: the "-f" and "-d" is optional.

0

I was encountering the same error "mount_smbfs: server rejected the connection: Authentication error" when attempting to connect via command line using the commands:

mkdir /Volumes/test
mount_smbfs //user@server/test /Volumes/test

However, I was able to elimate the error by going, on the server Mac, to System Preferences - Sharing - File Sharing - Options. Then under Windows File Sharing, click to enable the less-secure password option for the account you wish to use for sharing (optionally, create a sharing-only user for this purpose), and enter that account's password. I was then able to mount the share using the above commands.

-1

Are you by chance trying to authenticate to a Domain? Or specifically NOT wanting to use a Domain when the computer which hosts the remote filesystem is part of a Domain?

In my situation, my Mac is not on the domain, but the computer hosting the remote filesystem is on a domain. In order to force the remote computer to authenticate against a local user instead of a domain user, I have to use the keyword 'local' in the domain component:

mount -t smbfs '//local;user:password@S/F' /Volumes/Share
  • The question was self-answered 2 months ago and states what the solution was. If you believe this is a good enough new issue, feel free to post a new question and self-answer. – JakeGould Jan 4 '18 at 5:00
-1

Kind of solved:

in File Sharing I had to store the passwords of the users involved under "Options".

I don't like this.

-1

If you are able to mount your share from the Command-K window, you may be interested in this time saver I use. Mount all the smb//servers/shares you use. Then open a finder window and browse to your computer. You should see the mounted shares there. Drag them one by one ot the Favorites section of the Sidebar; they will remain there after you reboot or log out. The next time you want to mount them, assuming you've saved the credentials, all you need to do is click on the share in the Sidebar and you're in. Dumb but effective.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.