0

I have run sfc /scannow periodically ever since getting this laptop in March, and it never comes up with any errors. However, after the latest 1709 update (Fall Creators Edition) of Windows installed, I have been getting the message "Windows Resource Protection found corrupt files but was unable to fix some of them..." I was also having problems with the mouse and keyboard being completely unresponsive at times (I discovered that closing the lid and putting it to sleep, and then opening the lid again and waking it up made the mouse and keyboard return to normal), and also a blue screen - both problems that I had not had before the 1709 update.

I decided to re-install Windows, but I was concerned about losing some programs that came with the computer that weren't Windows programs, and therefore would be lost with a Windows re-installation (like the program that controls the backlight colors, which is nice). So I did a "Reset this PC" instead, but after doing so, I found that the "Windows Resource Protection found corrupt files but was unable to fix some of them..." error message was still there upon running sfc /scannow.

I've tried a different method - using the Media Creation Tool to update, as opposed to installing the update through Windows Update (which is what resulted in all the problems starting in the first place), but the same error appears when running sfc /scannow.

I tried a different method, going back to a back-up I made using AOMEI Backupper a few months ago (July), which was still under the 1703 update. After reverting to that disk backup, I then did the "Reset" again and then ran sfc /scannow - and it showed that no errors were found. However, I realized that the "Reset" resulted in a "clean" version of the 1703 update - not the 1709 update - being installed. So then I tried using the Windows10Upgrade9252.exe that I downloaded from the Microsoft website which installs the 1709 update itself, instead of using Windows Update or the Media Creation Tool (which had both resulted in the sfc /scannow error message). Again, after the 1709 update finished installing, the same error message appeared in sfc /scannow.

I've tried running "DISM /Online /Cleanup-Image /CheckHealth", "DISM /Online /Cleanup-Image /ScanHealth", and "DISM /Online /Cleanup-Image /RestoreHealth" - and then running sfc /scannow again, but it's still the same error message. I've tried running sfc /scannow in Safe Mode, but it's the same error message.

I see that others have also had problems after the 1709 update installed on their computers, but I don't think I've found any solution that applies to my particular problem. I don't know if this sfc /scannow error message is happening for everyone who installs the 1709 update, or if it's just me. Perhaps it's an issue with a new Windows build that they will fix eventually?

If anyone has any ideas on how to fix this problem - or if anyone can tell me whether this is "normal" to have this error message - I would greatly appreciate it.

Thank you all.

  • So which files are corrupt. Check the log. If you did a Reset then your programs had to be reinstalled but it also would mean that Windows was reinstalled. – Ramhound Nov 17 '17 at 23:43
  • I looked through the CBS.log file, but it's hard to make anything of it. Yes, I assumed Windows would be reinstalled, so it seems like there's something inherently corrupt in the 1709 update for me (but not necessarily for everyone else?) – ablewasiereisawelba Nov 18 '17 at 4:21
  • Oh, I think I see what the problem is. I looked through the CBS.log file again and did a search for "corrupt" and found that they're all in the C:\WINDOWS\System32\zh-tw\zh-tw\ and C:\WINDOWS\System32\zh-hk\zh-hk\ folders. Those must be associated with the "secondary keyboard layout" that they asked me if I wanted to add, during the 1709 installation (I chose "Traditional Chinese-Taiwan"). Let me try to reset it again without choosing any secondary keyboard layout (I don't really need it, I only chose one because they asked me to) and see if the sfc /scannow errors are no longer there. Thanks. – ablewasiereisawelba Nov 18 '17 at 4:29
  • Just uninstall the keyboard layout in question. Your system doesn’t need to be Reset again – Ramhound Nov 18 '17 at 13:39
  • It's still showing the corrupt files in the same folders - after uninstalling the secondary keyboard layout, restarting the computer, and running sfc /scannow again. I think I'll go ahead and reset it. – ablewasiereisawelba Nov 18 '17 at 14:51
0

That's a stupid bug.

There is neither C:\WINDOWS\System32\zh-hk\zh-hk\ nor C:\WINDOWS\System32\zh-tw\zh-tw\ directories. Only C:\WINDOWS\System32\zh-hk\ and C:\WINDOWS\System32\zh-tw\ exist.

The workaround would be to create the directories. Copy the the two files ChtAP.sdc and chtzhy.spd from C:\WINDOWS\System32\zh-hk\ to C:\WINDOWS\System32\zh-hk\zh-hk\ and from C:\WINDOWS\System32\zh-tw\ to C:\WINDOWS\System32\zh-tw\zh-tw\ respectively to the new directories.

Sfc should now show no corrupt files.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.