0

I have an ASUS ROG G750JH laptop. A few years ago, I ran into an issue with the touchpad that I've long since given up trying to find a fix and now use a mouse. I'm asking this on a whim in case anyone of you smart people can think of something I've overlooked.

The touchpad itself will move the cursor without any issue at all. The very bizarre part is that I can't tap to click. None of the gestures work (right click, double click, pinch to zoom, etc). The touchpad's physical right and left mouse buttons don't work either.

The laptop came with windows 8 installed and is now running windows 10. The touchpad worked fine on both OSs for a while. At one point I reinstalled windows 10 (installed windows 7, then did windows 10 upgrade). Since then, the touchpad has been like this.

It screams driver problem, but I have tried thoroughly uninstalling and reinstalling with the latest drivers. I've also tried installing the original Windows 8 drivers in compatibility mode without any luck either.

Everything I've found online says to update drivers or look for the FN key to disable/enable the touchpad. The touchpad is clearly enabled (or I couldn't move the cursor) and, as mentioned, the driver options have been tested pretty thoroughly. I've also made sure gestures are enabled in the ASUS Smart Gesture UI.

Anything else I can try? I'd love to be able to go without my mouse again.

  • 1
    It may or may not be related to the unusual way you reinstalled Windows 10, via upgrade form 7. You shouldn't do that, there's absolutely no need (Windows 10 ISOs are available directly from Microsoft), it was a huge waste of time and you may inadvertently installed Windows 7 in Legacy/CSM (BIOS) mode, something the subsequent upgrade to 10 didn't change. – user772515 Nov 19 '17 at 3:29
  • Touchpad should be of Elan Microelectronics. If you didn't it already, you can try the drivers from Driver Scape – spike_66 Nov 19 '17 at 8:54
  • Other drivers from Softpedia – spike_66 Nov 19 '17 at 9:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.