1

I have Microsoft Windows 10 version 1511 (OS Build 10586.679).

How can I make the console window full-screen? (Same as what we did in Windows XP.)

When I press Alt + Enter, the prompt This system does not support fullscreen mode. shows in a message box.

Explanation:

I mean to achieve a full screen mode, rather than just maximizing the window.

I have already read these questions:

  1. Fullscreen Vista's Command Prompt, or Replacement
  2. How can I use the Windows 7 command prompt in fullscreen?
  3. How do I full-screen my CMD?

The answers under above posts are about Maximizing or Command Prompt Properties, which is not an option in my question.

I need a true full screen mode without border or title bar.

So this tricky accepted answer is not full screen. I want to run old programs (such as the "Blood2" DOS game) immediately in Windows 10 CMD without using VMWare etc.

6
  • Some systems do not support full-screen console windows. Mine, for example, does and alt/enter works (RS3 build 16299, Radeon 6310 video card) – ddbug Nov 19 '17 at 22:56
  • How about if I installed Windows XP on my system? Is there any solution? – mgae2m Nov 19 '17 at 23:00
  • If you installed XP, you would be unsupported. Hope you don't :) – ddbug Nov 19 '17 at 23:04
  • @TwistyImpersonator, Please read the end of the question. – mgae2m Nov 20 '17 at 3:13
  • 2
    Press F11 when it opens make make it full screen. – Daniel Cheung Jun 27 '19 at 2:46
0

There are two simple solutions that I know:

  • Update your windows 10 [Start > Settings > Update and Security]
  • If updating does not work then rollback it,

Click here to Rollback

https://saintlad.com/downgrade-from-windows-10/

1
  • After updating / Rolling Back Alt + Enter might work . – Kingdom Fantastico Feb 6 '18 at 6:56
0

You will not likely be able to achieve what you want, since the old graphics card modes are no longer supported by Windows. I was very rarely able to run a DOS game from windows.

Note that cmd.exe is a Windows console application, which is entirely different from the DOS command shell. Switching to full screen will not change that. Running an .exe file from CMD is – barring changed environment variables – the same as running it from Windows Explorer.

Should you still wish to hide the title bar and borders, you can do so by following Daniel Cheung's comment: press F11 after starting CMD. Sould you also want to hide any scroll bar, you can additionally reduce the number of rows (or columns) in the properties, as you have already discovered. This comes at the expense of giving up the ability to scroll, but this is consistent with DOS behavior.

To play old DOS games, emulators are an option, for example DOSBox. It can be configured to automatically run a DOS game in its virtual file system and visually hide the fact that an emulator is run. A good example is provided by the folks at Good old Games, where the old DOS titles are wrapped in a hidden and well-configured DOSBOX.

0

I'm running Windows 10 1909 and when I press Alt-Enter, it goes full screen. There's a scrollbar on the right, but no titlebar. Alt-Enter again goes back.

It does not switch the system into physical text mode like it does in older versions of Windows. I think that went away when WDDM was introduced with Vista. In Vista you could still use older "XPDM" drivers designed for Windows XP and I believe those might still have switched to text mode, but not sure (been a long time since I've had a Vista system to play with).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.