12

So I want to move the photos on my OnePlus5 to my pc. My OS is Ubuntu 16.04. My PC recognises the device and also pops something up to install the drivers but none of them work for me.

screenshot here.

I've tried both of these that are for different OnePlus models but neither have worked: https://forums.oneplus.net/threads/detect-oneplus2-in-ubuntu-in-mtp-mode.365343/ https://stackoverflow.com/questions/33143928/how-do-you-connect-a-oneplus-two-device-to-ubuntu-through-mtp

4
  • 1
    Your screenshot also shows the"OnePlus" drive mounted. Ignore the one where you clicked. NO DRIVERS REQUIRED. – user772515 Nov 21 '17 at 2:18
  • As @MichaelBay said, have you tried opening the drive 'OnePlus? I had a device which shows up as a CD-ROM and a bunch of softwares/drivers inside it. They were for Reverse USB Tethering and of that sort. – RogUE Nov 21 '17 at 2:27
  • @MichaelBay, unfortunately when I click on the 'Oneplus" drive its completely empty. Even though I have lots of photos etc on my phone – Alex Marshall Nov 22 '17 at 23:23
  • 2
    So you need to open the dropdown menu in your Android phone, tap the USB settings and select MPT for everything but photos or PTP for photos only. You need to learn how to use your hardware. – user772515 Nov 23 '17 at 0:06
20

What you want to do is to configure your phone's USB settings for MTP (Media Transfer Protocol). Unfortunately, this is hidden away deep in the Developer Settings on recent OnePlus 5 phones. To enable Developer Options, go to the phone's "About Phone" page (in the settings) and tap the build number 7 times.

Then, open the Developer Options (from System Settings), enable it, and look for the Default USB Configuration option. Change it from "Charging only" or "No data transfer" (probably the default) to "MTP"/"File transfer". Then, your phone should work like any other USB storage device.

1
  • On Android Pie it's at Settings -> System -> Developer options - > Default USB Configuration -> File Transfer – JBSnorro Mar 19 '20 at 22:49
1

None of the answers above worked for me, I had to select the "File transfer" option, then install adb

 sudo apt install android-tools-adb

Then execute the .sh file found in one of the mounted drive:

source ./adb_config_Linux_OSX.sh

Only then was I able to see an "Internal Shared Storage" icon in the other mount drive, containing all the files of the device.

1
  • This worked for me. – akungta Sep 10 '20 at 21:40
0

I have a Oneplus 5T and had a similar issue however I don't see an MTP option. I tried the "File Transfer" option and got visibility of files similar to those in the image above.

For me the solution was: Settings -> Bluetooth & device connection -> USB -> PTP

This enabled Ubuntu to see my phone's DCIM directory and the photos.

0

for one plus 7, go to settings -> system -> otg storage and toggle otg storage to ON. It will remain ON for 10 minutes. But if you are doing some work accessing the drive, it will continue to be available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.