0

First of all, apology if this question has been already asked. I saw similar questions on the Internet but none of the answers work in my case.

I look after a call center with 50 odd PCs (running Windows 7) and around 90 staff members. Multiple shifts a day. Everyone sits there they want (if they are early enough) or where it's free ( if they aren't :) ). This causes me problems where deploying software, since in many cases I need to install software on each user on each PC. That's like 5000 installs.

Today I need to install and auto run a software for each user. In this case it is a single .exe file so I don't need to install it - simple copy is enough. To save me some time I thought I would copy this file into:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup

on each PC. This will allow me to do only 50 installs (once on each PC) rather than for each user. This will also cause the program to auto run every time a user logs into the PC.

The problem I face is that when the program runs, it produces a confirmation dialog box asking whether to run the program or not. Users can click on "Run" with no problems; however, it is far from ideal for reasons I don't want to bore you with.

I want this software to auto run silently but I'm not sure how to do it. There is a checkbox on the dialog box saying "Always ask before opening this file". When I un-tick this and press "Run" it asks me for admin details. I put them in and it runs; however, when I log off, log back in next time, the windows still pops up.

How do I make the software to run silently? Any suggestions are welcomed.

Thanks for your input everyone!

Screenshot of the message is below. Also, I can confirm users do not have local admin permissions, and the software does not require admin permissions for the users to run.

enter image description here

4
  • 3
    Please attach a screenshot of the actual message you are receiving when the application runs. There are a few very similar messages, and the one you are seeing is important. Also, I’m guessing from your post that your users do not have local admin permissions, and the software does not require admin permissions for the users to run? – Appleoddity Nov 21 '17 at 18:07
  • Hi Appleoddity, thanks for your efforts. I have updated the question. – Piotr Zurek Nov 22 '17 at 11:41
  • @PiotrZurek If the said ".exe" can take arguments(options) from command line, there is always the chance it has a silent mode, so you could check that by executing it from cmd "your.exe /?" (-? , /help, -help , -h, /h, etc). Other way is and copy it that way and add the execution on the TaskSchudler. Last method would be C:\> Runas /profile /user:domain-or-pc\yoursisadminname your.exe write that in a text editor and save it a ".bat" – dmb Nov 22 '17 at 12:11
  • Thanks to all who made an effort in responding to my query. In the end I figured it out myself. It appears that ticking the "Always ask before opening this file" box, as non-admin user, didn't do all; however, ticking that box as an admin user stopped the message from reappearing. Now the file is run silently (even in a non-admin user). I have replicated the error (and the fix) on other PCs, so the solution seems to be legit. – Piotr Zurek Dec 5 '17 at 17:05
0

For this message, please see if you can unblock the file by modifying the file's properties.

Navigate to the folder that contains the file in question, then right-click the file, and click Properties.

Look for and check the box the says "Unblock" under the General tab, then apply the settings.

enter image description here

https://www.howtogeek.com/256303/how-to-unblock-a-file-from-windows-publisher-could-not-be-verified-warning/

0

Thanks to all who made an effort in responding to my query. In the end I figured it out myself. :)

It appears that ticking the "Always ask before opening this file" box, as non-admin user, didn't do all; however, ticking that box as an admin user stopped the message from reappearing. Now the file is run silently (even in a non-admin user).

I have replicated the error (and the fix) on other PCs, so the solution seems to be legit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.