2

For years I've used Comcast and have had port 80 open to a web server at my house, without issue. I switched to CenturyLink fiber last week and port 80 forwarding works and my server is also visible to the outside world.

If I am at home and on the same local network as the web server (everything connected to the same router), I cannot access the sites by using the domain names. If I sign onto a VPN or turn wireless off on my phone, I can see the site by using the domain name.

I'm at a loss. Does anyone have any idea why this would happen?

  • CenturyLink fiber connection
  • C2100Z modem/router combo
  • Can you clarify what you mean by ‘‘I cannot access the domain name when I share an external IP with the server.’’?   Please do not respond in comments; edit your question to make it clearer and more complete. – G-Man Says 'Reinstate Monica' Nov 22 '17 at 2:26
  • You probably do not have an internet facing IP address and are therefor not routable without the ISPs NAT which doesn't forward back to your IP. Check the IP address that your router has on its "WAN" and check if you can what the ip address is of your Modem. – jdwolf Nov 22 '17 at 2:28
  • How do you know that your server is visible to the outside world? Check port 80 with porttest.net. – SpiderPig Nov 22 '17 at 2:44
  • @G-Man I've edited my question. Let me know if I'm still not being clear - it's a tough thing to try and describe. Thanks! – frankiejr Nov 22 '17 at 2:49
  • @SpiderPig I can access the site by domain name if I sign onto a VPN or use my phone and turn off wireless (so I'm on the cellular network instead of the local wireless connection). – frankiejr Nov 22 '17 at 2:50
3

It sounds like the problem is that your router does not support or has disabled NAT Loopback.

If you can't enable this feature, then the solution is to have your domain name resolve to the proper internal IP address for machines on your network. If it's only a couple of machines, you could do this using a simple hosts file override. For a larger network you could setup your own local DNS server that resolves your domain instead of relying on upstream DNS servers.

Not the answer you're looking for? Browse other questions tagged or ask your own question.