0

I have an toshiba sattelite c50. It won't boot any longer from any bootable device (hdd, (intern, extern)cdrom, usb)

All the bootable devices are MBR partitioned and work on other laptop/pc.

situation before problem occurs:

  • (bios settings) See images for my bios settings>

security tab https://ibb.co/jFvPcm

power mngmnt tab https://ibb.co/jSe6q6

advanced tab https://ibb.co/bDu6q6

advanced sub menu https://ibb.co/kvfeA6

Mainoverview (seems to be oke, just an overview)

Boot menu in bios (recognizes all devices internal, external)

Boot menu retrieved after hitting F12 (while booting) is oke, can boot from any device.

  • (hardware)

Hdd with xen hypervisor for test purposes (running 2 fedoras) Perfect booting without problems.

Till now (yesterday): i wanted to boot as normally my laptop but now he doesn't boot but give me an message "No bootable device -- Please restart the system".

  1. New RAM memory tried from another laptop and reverse -> retrieve same error

  2. i try an live linux usb and an internal, external cdrom to boot but --> same error

  3. To see if any hardware is broken i pulled out any hdd, cdrom and boot only from usb but --> same error.
  4. hdd and usb tested on another laptop an pc --> boot perfect, devices oke.
  5. Battery and bios battery pulled out for a whole night, i resetted bios settings via bios interface but --> same error.

All the hardware is well recognized in the bios.

Boot menu retrieved after hitting F12 (while booting) displays the boot-devices menu and when i entered an boot device the 'boot menu page' just refresh and do not boot.

I dont know what to do with it anymore. Can anyone help me with this issue?

Thx!

0

The Boot Mode setting in "advanced sub menu" of your BIOS settings indicates the system is configured for CSM Boot, which is what you want when booting from MBR-bootable devices.

However, only the top part of the "security tab" is visible, and it might contain an important setting: if Secure Boot is enabled, the CSM Boot might be impossible, as Secure Boot requires UEFI-style boot procedures.

The help text for Boot Mode indicates that setting won't be reset if the BIOS settings are reset to default settings. But if the Secure Boot setting does not have similar protection, it might have caused a combination of settings that makes booting impossible. That would ultimately be a mistake on the BIOS programmer's part.

  • Hi thanks for the reply. My security page only contains these two functions displayed on the picture. (It seems to be secure boot not possible here. (The pic is from internet but 100% same settings as mine bios) – benny d Nov 22 '17 at 14:02
  • You might try temporarily switching Boot Mode to UEFI, just in case it brings the Secure Boot-related settings visible in the BIOS menus. If it does, first disable Secure Boot, only then restore the Boot Mode to CSM. – telcoM Nov 22 '17 at 14:09
  • Do you know if the chances are real to be it a virus? – benny d Nov 22 '17 at 14:09
  • I will give it a try. I shall feedback you. – benny d Nov 22 '17 at 14:14
  • If it was a virus, it would be quite a self-defeating one: preventing a system from booting would also stop the virus from spreading. I guess it would be possible, but I think a virus behaving like this is not very probable. Could you describe how the Boot tab of the BIOS settings looks like? – telcoM Nov 22 '17 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.