8

I recently downloaded Firefox the new version, and for most of the part it is good. Though a problem in it I found is that every time I open a new web page I need to set the zoom level to 170% so that the page becomes readable and fits the screen size. How can I set it once and for all?

Note: I am using a Windows 10 machine.

4

This is one of those things that I've found perpetually frustrating with Firefox. I was using NoSquint for a while, but I found it to be a somewhat inconsistent and gnarly plugin to use. And now it's no longer being maintained and doesn't work with the most recent versions of Firefox.

Until the team at Mozilla do the sensible thing and reinstate this basic accessibility feature, I think the best extension-free solution can be found in a comment on this bug ticket. In case that link ever breaks, I'm reposting the contents below:

  1. Open Browser Console (https://developer.mozilla.org/en-US/docs/Tools/Browser_Console#Opening_the_Browser_Console)
  2. On the command line (https://developer.mozilla.org/en-US/docs/Tools/Browser_Console#Browser_Console_command_line):

    To Set Global Zoom (put whatever you want instead of 1.33) enter: FullZoom._cps2.setGlobal(FullZoom.name,1.33,gBrowser.selectedBrowser.loadContext);

    To Reset (back to 1) enter: FullZoom._cps2.removeGlobal(FullZoom.name,gBrowser.selectedBrowser.loadContext);

To be clear, the number here represents a decimalised version of zoom percentage. So as with the original question, a zoom level of 170% would be expressed as 1.7.

|improve this answer|||||
  • 1
    My God. (and I'm an atheist). A 13-year-old thread reaching a hundred comments about something so fundamental. I wonder if they ever thought about using a fraction of the time they spent discussing this to actually go ahead and implement it. In the words if Linus Torvalds: Talk is cheap. Show me the code. – Marc.2377 Mar 12 '19 at 2:43
  • /\ And I do realize this applies to my little rant just as well. – Marc.2377 Mar 12 '19 at 2:44
3

You can set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. Adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right. Modifying layout.css.devPixelsPerPx affects user interface and web pages (global zoom). You can use an extension to correct the appearance of web pages.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

http://kb.mozillazine.org/about:config

|improve this answer|||||
3

May be a little bit late, but... I was looking to solve the same problem today and this is how I got here. For whoever this may be useful, I found in about:config the setting zoom.minPercent (Firefox 62). This sets the default zoom to all pages to the given value. It is hackish because you cannot zoom-out more (less) than this value, but I could not find anything better. Regards.

|improve this answer|||||
0

It seems that many people still visit this post looking for a solution, so for here it is. You can install the Firefox add-on Zoom Page WE, then in the add-on preferences page go to Zoom Levels & Font Size tab and set the Default Full Level to whatever is best for you. On a 15'' FHD screen I found 150% works best for me.

|improve this answer|||||
  • That extension is extremely clumsy and resource-consuming. – UnclickableCharacter Sep 24 '19 at 9:59
  • It works very well on my laptop that has only 4 GBs of RAM. – Tofi Oct 4 '19 at 20:20
  • "Works on my laptop" is anecdotal evidence. It represents only one usage scenario and 4GB of RAM means you won't be even able to open a considerable amount of tabs. – UnclickableCharacter Oct 5 '19 at 6:00
0

This will soon be available under Preferences -> Language and Appearance see https://bugzilla.mozilla.org/show_bug.cgi?id=1590485#c28

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.