0

I have a Retina iMac, and I run Debian-9 under a VMware Fusion 8.5.9 virtual machine. Debian-9 has changed the windowing system to something I can't trace out: ps shows gdm3 running a gdm-wayland-session and Xwayland, and after I log in, there's another gdm-session-worker that runs Xorg (which I am familiar with).

   630 ?        Ssl    0:00 /usr/sbin/gdm3
   656 ?        Sl     0:00  \_ gdm-session-worker [pam/gdm-launch-environment]
   747 tty1     Ssl+   0:00  |   \_ /usr/lib/gdm3/gdm-wayland-session gnome-session --autostart /usr/share/gdm/greeter/a
   823 tty1     Sl+    0:00  |       \_ /usr/lib/gnome-session/gnome-session-binary --autostart /usr/share/gdm/greeter/a
   850 tty1     Sl+    0:01  |           \_ /usr/bin/gnome-shell
   951 tty1     Sl+    0:00  |           |   \_ /usr/bin/Xwayland :1024 -rootless -noreset -listen 4 -listen 5 -displayf
   984 tty1     Sl+    0:00  |           \_ /usr/lib/gnome-settings-daemon/gnome-settings-daemon
  1292 ?        Sl     0:00  \_ gdm-session-worker [pam/gdm-password]
  1306 tty2     Ssl+   0:00      \_ /usr/lib/gdm3/gdm-x-session --run-script default
  1308 tty2     Sl+    0:00          \_ /usr/lib/xorg/Xorg vt2 -displayfd 3 -auth /run/user/501/gdm/Xauthority -backgrou
  1316 tty2     Sl+    0:00          \_ /usr/lib/gnome-session/gnome-session-binary
  1364 ?        Ss     0:00              \_ /usr/bin/ssh-agent x-session-manager
  1396 tty2     Sl+    0:03              \_ /usr/bin/gnome-shell
  1489 tty2     Sl+    0:00              \_ /usr/lib/gnome-settings-daemon/gnome-settings-daemon
  1516 tty2     SNl+   0:00              \_ /usr/lib/tracker/tracker-extract
  1526 tty2     SNl+   0:00              \_ /usr/lib/tracker/tracker-miner-fs
  1530 tty2     SNl+   0:00              \_ /usr/lib/tracker/tracker-miner-apps
  1543 tty2     Sl+    0:00              \_ /usr/bin/gnome-software --gapplication-service
  1546 tty2     Sl+    0:00              \_ /usr/lib/evolution/evolution-alarm-notify
  1550 tty2     SNl+   0:00              \_ /usr/lib/tracker/tracker-miner-user-guides

I got Xorg to use full Retina resolution by adding a config file to /usr/share/X11/xorg.conf.d:

user:/usr/share/X11/xorg.conf.d$ cat 20-imac27.conf 
Section "Monitor"
    Identifier "27-inch iMac Retina Display"
    DisplaySize 597 336
    Modeline "5120x2880"  1276.50  5120 5560 6128 7136  2880 2883 2888 2982 -hsync +vsync
    Modeline "2560x1440"   312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
EndSection

Section "Screen"
    Identifier "Default Screen"
    Monitor "27-inch iMac Retina Display"
    DefaultDepth 24
    SubSection "Display"
        Modes "5120x2880" "2560x1440"
    EndSubSection
EndSection

But the initial gdm greeter shows up on a low-res screen.

How can I provide a ModeLine to Xwayland so that the greeter screen is also at full Retina resolution?

  • Update: You can switch from Xwayland back to Xorg for the greeter by uncommenting WaylandEnable=false in /etc/gdm3/daemon.conf. This fixes my main concern (greeter using low screen resolution) but doesn't address the question, how to make Xwayland use a different resolution. – Dave M. Nov 24 '17 at 19:04
0

I don't know if this would work in your setup. But, taken from the Arch documentation that has worked for me, I can refer this:

Some desktop environments store display settings in ~/.config/monitors.xml. xrandr commands are then generated on the base of the file content. GDM has a similar file stored in /var/lib/gdm/.config/monitors.xml.

If you have your monitors setup as you like (orientation, scaling, primary and so on) in ~/.config/monitors.xml and want GDM to honor those settings:

$ sudo cp ~/.config/monitors.xml /var/lib/gdm/.config/

$ sudo chown gdm:gdm /var/lib/gdm/.config/monitors.xml

I hope it helps

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.