I'm not sure where to go for help with this. I already posted in the Google Product Forums for help with Chrome.

Several weird things started happening with my Chrome a few months ago. It started off by sometimes not displaying embedded Google Maps as well as maps on the Google Maps page, which I found out to be due to some 400 errors by looking at the console. Maps were fine in Safari logged under the same account.

I also started getting some 400s when going to pages such as gmail.com which redirects to https://www.google.com/gmail/. I could only visit my email by visiting https://mail.google.com/mail/u/0/. I tried logging out of both of my accounts, only to have the same happen.

Last night it all went to crap. Whenever I went to my Gmail account (the link that actually worked), the browser would freeze ("Application not responding") and I would have to force quit it. The same happened whenever I tried to go into Chrome Settings.

Today, no pages will open at all. I get the loading animation and the "Untitled" tab title, like in this image.

I tried deleting Google Chrome from my Applications folder, to no avail. I then tried backing up my ~/Library/Application\ Support/Google/Chrome folder, quitting Chrome and deleting the original folder. When relaunching Chrome, it behaved like it were a fresh installation, saying installation was ready and asking if I wanted to set it as default browser, etc. Even then, it would not open any pages, and gets stuck at the same loading/untitled state.

I can't check my Chrome version as chrome://help won't load when I click "About Google Chrome", but I would assume it's the latest version as I couldn't check for updates.

I also downloaded Chrome Beta and Chrome Canary and the same happens. Tabs keep loading and then I get a window saying they have become unresponsive and asking whether I want to exit the page or wait. All the while I do get search suggestions on the omnibox.

I'm not sure what to do, and any insight would be appreciated as I don't want to have to keep using Firefox.


Ended up upgrading my macOS to High Sierra and it must have cleaned something in Chrome's files because it started working again. Still no clue as to what caused the problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.