4

For a while now my pc keeps reminding the programs I had open after a shut down.

I found some messy ways to solve this but its just extra work for something that should be very simple.

For example this command:

shutdown /r /t 0

Or going to your desktop and pressing alt+f4.

If I want to keep my last session I'll just let my PC sleep like everyone did for the last decade and don't shut it down.

Is it possible to stop this 'new Feature' and just start with a clean session after a shutdown?

0

3 Answers 3

7

The problem is that Windows 10, in an effort to speed up boot times, doesn't really shut down when you ask it to: instead, with the default settings, it hibernates.

To change this, you need to find a well-hidden option in the power settings - go to Control Panel -> Power Options: enter image description here

Click on Choose what the power options do and then on Change settings that are currently unavailable: enter image description here

You can now change Turn on fast start-up (recommended) by removing the tick. When you click on Save Changes, shut-down will now really shut down.

7
  • Because it's related, I'll add that turning hibernation off (by powercfg -h off in an elevated commad prompt) by extension achieves the same thing, in addition to deleting the hiberfil.sys file from the C: drive.
    – Kitet
    Nov 23, 2017 at 23:19
  • 1
    @Kitet - I wouldn't delete hiberfil.sys, because you can still configure Hibernate as a separate, additional option to Shut down, which is useful when this is what you want to do instead of a complete shut down. There is no rational reason for not making Sleep, Hibernate and (true) Shut down as three distinct options in the Shut Down... submenu by default.
    – AFH
    Nov 24, 2017 at 0:32
  • @AFH Thanks alot I'm pretty sure thats the option I'm looking for! :-)
    – Stefan
    Nov 24, 2017 at 13:35
  • @AFH After using this option some days my windows 10 decided again to remind every program I had open...... I checked if Turn on fast start-up (recommended) got selected again but it didn't. Maybe this doesn't solve my exact problem?
    – Stefan
    Nov 30, 2017 at 8:42
  • I can't think how this can have happened. There is an Explorer option to remember all open windows for next time when it closes, and other individual applications may have similar options, but after hibernation you will see all programs in the same states as before hibernation, including unsaved edits, etc. Is this what you are seeing? One way to make absolutely sure that a system is properly shut down is to select restart and power off when the BIOS appears, but of course that means staying at the machine until shut-down is complete.
    – AFH
    Nov 30, 2017 at 12:25
0

For future readers, I solved this problem with the AFH's answer + other configurations.

Steps:

Control Panel / Power Options / Choose what the power buttons do / Change settings that are currently unavailable:

When I press the power button - On battery: sleep | Plugged in: sleep

I changed this setting to:

When I press the power button - On battery: shutdown | Plugged in: shutdown

-2

It appears this new "feature" has no "switch off" option yet in windows 10. http://www.winhelponline.com/blog/stop-auto-reopen-programs-restart-windows-10/ So many people wanted this feature, so they added it to the windows 10 creators update. There are some solutions posted, but my best guess is you ask Microsoft for a option to turn this off.

I can image other options, but that involves going away from Windows 10 or install third party software or scripts that might not work with a new update.

3
  • Link-only answers are not that helpful
    – Ramhound
    Nov 23, 2017 at 22:40
  • This "feature" was present since Windows 8.1 (maybe even Windows 8) and caused many checkdisks in dual-boot system in the scenario, where you shut down (hibernate) and start up system from another drive afterwards. Both systems treated Windows 8.1 drive as dirty then. Since then I never hibernate, saves my SSD.
    – Kitet
    Nov 23, 2017 at 23:23
  • @Kitet The feature the author is asking about is entirely different then the feature you describe
    – Ramhound
    Nov 24, 2017 at 0:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .