2

I have been trying to get my wireless working with Debian Linux for the past month now with no avail. I am using an Asus Rampage V Extreme with a wireless card: Broadcom Broadcom Limited BCM4360 802.11ac Wireless Network Adapter (rev 03).

I have obtained multiple versions of the windows driver and tried to install them using Ndiswrapper, none of which have worked. I have followed all the online tutorials.

lspci gives me:

05:00.0 Network controller: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter (rev 03)

ndiswrapper -l gives me:

bcmwl64 : driver installed
device (14E4:43A0) present (alternate driver: bcma)

ip addr gives me:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether f0:79:59:62:b3:e0 brd ff:ff:ff:ff:ff:ff
inet 192.168.0.111/24 brd 192.168.0.255 scope global dynamic eno1
   valid_lft 83876sec preferred_lft 83876sec
inet6 fe80::2561:950f:c23c:4fd7/64 scope link 
   valid_lft forever preferred_lft forever

I am about 3 months into learning Linux so I am not an expert but by no means am I a novice.

If you need more info, leave a comment and I will add it ASAP.

Any help appreciated!

0

Use the drivers from here and follow the instructions.

1:

apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

2:

modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

3:

modprobe wl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.