Pretty basic question:

I enter services.msc on Windows 10.

I navigate to DNS client

I right-click to restart DNS client

All options are greyed out (start, stop, restart).

How do I fix this?

Note: I tried opening services by right-clicking and choosing "Run as Administrator" - did not fix the issue.


2 Answers 2



I found the I was able to use regedit to disable dnscache.

I will say that it is ridiculous to lose the ability to change this from the services control panel. I also tried disabling it using msconfig and even unchecking the box didn't disable it.

Here are the directions the finally worked.

win+x run regedit

Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Dnscache and locate Start registry key

Change Startup type :

Automatic -2 Manual -3 Disabled -4 Automatic (Delayed Start) -2


Restart Dnscache in new Windows 10 (where Dnscache placed in isolated process) via PowerShell:

$ServicePID = (get-wmiobject win32_service | where { $_.name -eq 'Dnscache'}).processID
Stop-Process $ServicePID -Force

Place code:

PowerShell.exe -WindowStyle Hidden -NoProfile -NoLogo -Command "try { $ServicePID = (get-wmiobject win32_service | where { $_.name -eq 'Dnscache'}).processID; Stop-Process $ServicePID -Force } catch {}"

into bat-file and this able to automatization.

  • This should become the right answer, thanks!
    – K_Rol
    May 23, 2021 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .