I asked this question 1day ago in stackoverflow but there is no answer for it until now, but I need it now, So I asked it here again:

I want to install JavaScript on my ARM-based(arm7) board with Armbian 5.3(Ubuntu-Server 16.04). As it says here: https://chromium.googlesource.com/v8/v8/ I need to install depot_tools and as it says here: https://commondatastorage.googleapis.com/chrome-infra-docs/flat/depot_tools/docs/html/depot_tools_tutorial.html I did this commands:

cd /home/m
mkdir depot_tools
    git clone https://chromium.googlesource.com/chromium/tools/depot_tools.git
   `export PATH="$PATH:/home/m/depot_tools"`

Then I tried : fetch v8 but I got:

"-bash: fetch: command not found"

  • Normally when you clone, it creates the folder for you. See if fetch is in /home/m/depot_tools/depot_tools
    – Paul
    Nov 28, 2017 at 5:55
  • @Paul: yes, there is a file named fetch there Nov 28, 2017 at 5:57
  • Can you go into /home/m/depot_tools/depot_tools and run fetch v8 from in that path? Note: You may need to chmod +x to make fetch executable (if it is not yet done already). (or maybe ./fetch v8)
    – Darius
    Nov 28, 2017 at 6:01
  • @Darius: thank you it works fetch v8 . So how should I change this line: ` --enable-javascript --with-v8-path=/path/to/v8 ` Nov 28, 2017 at 6:09
  • Also this is the result after runningfetch v8 command: Running: gclient root Running: gclient config --spec 'solutions = [ { "url": "chromium.googlesource.com/v8/v8.git", "managed": False, "name": "v8", "deps_file": "DEPS", "custom_deps": {}, }, ] ' Running: gclient sync --with_branch_heads Nov 28, 2017 at 6:11

2 Answers 2


These commands:

cd /home/m/depot_tools
git clone https://chromium.googlesource.com/chromium/tools/depot_tools.git

will clone the tools into /home/m/depot_tools/depot_tools

So you need to either adjust your path to match:

export PATH="$PATH:/home/m/depot_tools/depot_tools"

Or move everything to the folder above so that your current path is correct:

shopt -s dotglob nullglob
mv /home/m/depot_tools/* /home/m/depot_tools

(the shopt command will make sure * matches hidden files, so the git folders will be moved too)

  • Thank you paul, may you check the comments of question too? Nov 28, 2017 at 6:13
  • @user145959 if you do the mv suggested here, the you can follow the instructions as is
    – Paul
    Nov 28, 2017 at 6:20
  • OK, I did edit my question entirely and removed and tried the steps from first, so what will happen after this step? Nov 28, 2017 at 6:28
  • @user145959 Please don't do this, if you have a different.question open a new one. This answer no longer makes sense. I'll revert your edit.
    – Paul
    Nov 28, 2017 at 6:31
  • Crap, I can't on mobile, please revert your edit and open a new question
    – Paul
    Nov 28, 2017 at 6:33

Just Type in your terminal this


And then type what you what fetch to do e.g chromium or ios

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .