1

I have a brand new laptop.....well, 3 months or so. a 1TB SSD and a 1TB HDD. It is a Lenovo ThinkPad Workstation Laptop P50 with Xeon processor, 64GB DDR4, a 1TB SSD and a 1TB HDD, Discrete Graphics with 4GB of VRAM & every port you can imagine.

I'm using VMware to separate my graduate school work from my main computer. On the host OS, I have Windows 10 Professional. These are my guest VMs: Windows 10 Education, Windows 7 Ultimate, Windows 7 Pro, Windows XP, Kali Linux, Ubuntu Server, OSX, and some other fun toys.

My SSD is running all of the VMs, but only the Windows 10 Education with a maximum virtual hard drive of 500GB (currently only at 180GB) is located on my SSD. With the OS, games, programs, etc. I eat up another 200GB. So that means I should have at leadt 600GB free on my SSD, but it shows less than 30GB. I used TreeSize to attempt to find the largest files on the SSD and found a 300+GB file called gms.log. The file is located at %systemroot%\sysWOW64\gms.log.

From googling the problem, I found that it could be attributed to Intel Management Engine or Intel Management and Security Application. I uninstalled them but the problem persists.

What am I missing here?

EDIT: I tried deleting the file, but it wouldn't let me.

  • “Wouldn’t let me” doesn’t tell me very much. Take ownership of the file then delete it – Ramhound Nov 28 '17 at 22:50
  • How would I take ownership of the file so I can delete it? – rockower Nov 29 '17 at 14:47
2

What am I missing here?

You uninstalled the software that generated the log file. However, you forgot to delete, the log actual file. Most uninstallers do not delete user generated files.

Just delete the file in question.

I tried deleting the file, but it wouldn't let me.

You need to take ownership of the file before you can delete it.

enter image description here

You can also just run the following two commands in an elevated command prompt. Once these commands are ran, only a user in the Administrator group, would be able to delete the file in question.

takeown /F C:\Windows\SysWOW64\gms.log /A /R /D Y

icacls C:\Windows\SysWOW64\gms.log /setowner "Administrators" /T /C

Sources

  • I tried deleting the file but it won't delete for me. User-permission denied, even though I am logged in as an administrator. I even tried to delete it after a reboot and I get the same problem. – rockower Nov 28 '17 at 19:27
  • You can't delete the file. You made no mention of that fact in the question body. If you make that statement you must provide specifics. Otherwise I cannot edit my answer. – Ramhound Nov 28 '17 at 19:49
  • I edited the question to make sure it includes the problems of deleting the file. – rockower Nov 28 '17 at 22:28
  • 1
    How to Add “Take Ownership” to the Right-Click Menu in Windows Explorer. Since you don't even know how to take ownership of a file, I provided this tutorial, so make the task easier. – Ramhound Nov 29 '17 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.