3

I have a relatively new USB 3 hard disk: Seagate 2TB Backup Plus Slim Portable External USB 3.0 Hard Drive (Silver) Also, I have an USB 3 SD card reader. Both of these are known to work faster than they do now. They perform at 40-45 MB/s.

I use USB Device Tree Viewer V3.1.2 and it tells me these, for both devices:

Device Bus Speed         : 0x02 (High-Speed)
Flags                    : 0x02
 DevIsOpAtSsOrHigher     : 0 (Is not operating at SuperSpeed or higher)
 DevIsSsCapOrHigher      : 1 (Is SuperSpeed capable or higher)
 DevIsOpAtSsPlusOrHigher : 0 (Is not operating at SuperSpeedPlus or higher)
 DevIsSsPlusCapOrHigher  : 0 (Is not SuperSpeedPlus capable or higher)

My motherboard is ASUS MAXIMUS V GENE and it has two USB 3 options. There is ASMedia USB3.0 eXtensible Host Controller and there is also Intel(R) USB 3.0 eXtensible Host Controller. I never got any device to work at USB 3 speed on the Intel. They don't supply drivers for Windows 10 64bit as it is already included in the OS. Then I started plugging devices to the ASMedia ports, and they worked in the past. But I checked again and now all devices are using USB 2 speeds on these ports too. I think what messed it up was a recent Windows Update. I used IObit Driver Booser which complained that the driver was too old for this controller.

Driver: \SystemRoot\System32\drivers\asmtxhci.sys (Version: 1.16.47.2  Date: 2017-11-28)

No joy, even tried manually installing specific drivers. ASUS has this as "latest driver" on their site: Asmedia_USB3_V1.16.35.1 I downloaded it and installed it. Install is successful:

Driver: \SystemRoot\System32\drivers\asmtxhci.sys (Version: 1.16.35.1  Date: 2016-04-14)

But no USB 3 speeds whatsoever. I ran out of options to try.

enter image description here

enter image description here

9
  • Can you provide the information on each by submitting a screenshot of the device manager similar to this question. Do not submit this information as a comment.
    – Ramhound
    Nov 29, 2017 at 17:35
  • The max theoretical sustained for that drive is 100, but sustained is a special case for large files, and small random reads will be dramatically slower. Have you tried a simple testing tool like winsat -drive {drive letter, no colon} to get an accurate picture of best case/worst case? I have pulled drives out of enclosures and still gotten less than their rating plugged using internal SATA numerous times. USB-3 is an oval track with banked curves for race cars, but your horse won't get faster simply by being on the track.
    – Yorik
    Nov 29, 2017 at 19:14
  • USB3 is an interface standard, not a drive specification. It is a forward looking specification. If it was only as good as current drives it would have been obsolete when introduced. If at some future date a conventional drive is capable of that speed the interface will be ready. At the present time only a fast SSD can provide that kind of speed. For a 5400 RPM conventional drive 100MB/s is quite good.
    – LMiller7
    Nov 29, 2017 at 20:34
  • @Ramhound Done. Nov 30, 2017 at 14:54
  • @Yorik I tested with HD tune and when it worked it shown a nice curve graph, but in USB 2 mode it's flat. It's not about what the drive or the SD card is capable of, I've seen both work much faster on this very system. Nov 30, 2017 at 14:56

2 Answers 2

3

Based on submitted information, all it means that your host USB system is crippled, and initial negotiations into USB3 mode fail. So the devices fell back into USB 2.0 mode. The fact that it happens on two different controllers points to some software (or BIOS hardware configuration) issue.

To rule out post-configuration hardware issues, try to boot your system from an external DVD-Rom drive into something like latest Knoppix, or any other recent CD-bootable Linux, and see if your USB 3.0 functionality is there. If not, you might need to downgrade your UEFI/BIOS to the original manufacturer's state, and check the USB 3.0 functionality again.

Your mainboard uses a 5-years-old old Z77 chipset, so it is possible that the newest software update, while is the latest and greatest, but not for older chipsets, so some workarounds (aka "filter drivers") between Microsoft and Intel have expired.

1
  • I booted in from Knoppix but I was totally lost as I never used linux. Couldn't perform a disk performance test, even though I saw the drive. Changed around a few settings in BIOS regarding USB3 legacy mode, nothing. Nov 30, 2017 at 15:34
1

In the end, it turned out that the cable Seagate has supplied with the drive, was bad. Its connection towards the drive was flimsy. I haven't moved it a lot as I thought it was a software issue. I bought a new sturdy cable, thrashed the old, now the connection is very strong and all the USB issues are gone, no matter which blue port I plug into. I also bought a PCI-E card for more USB3 ports and I started using those, just in case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.