4

I have HyperX Alloy Elite Keyboard to use with Linux (Ubuntu) and Windows 10, but I recently got MacBook Pro 2017 for Work and I'm unable to use this Keyboard with macOS.

When I try to setup keyboard using macOS Keyboard Wizard (by pressing mentioned keys as wizard suggests), it doesn't recognize my keyboard;

Keyboard cannot be identified

However, the keyboard is recognized in other places of the OS like;

  • Modifier Key Settings

Modifier Key Settings

  • System Report

Keyboard Details in System Report

But the key layout is all messed up, and keys are entirely swapped.

  • q points to x
  • w points to 4
  • `~ points to F3
  • Esc points to ]
  • Enter points to [
  • Spacebar points to ;

And so on...

However, Shift, Ctrl, Option and right Win (which points to Cmd) is mapped correctly.

Also, I have basic Dell USB keyboard which works just fine, so is there any way I can make my mechanical keyboard function correctly? any help is appreciated.

Update

HyperX confirms that this particular keyboard is not compatible with Mac and is only compatible with Windows, but then that's the case with almost every Gaming keyboard out there, and again, even Linux support is not advertised but this keyboard works perfectly with Linux (incl. media keys).

Update March 2018

As per @Reno's answer below this problem can indeed be fixed by flashing latest firmware to the keyboard, however, the firmware itself is nowhere listed on HyperX website, and I managed to find it from this Reddit thread, and while I took the risk of updating the firmware by downloading the updater from someone's dropbox, I know it is hard to trust this method so I'm still open to answer that can point me to official HyperX page with firmware download.

Also it is worth noting that even when I updated the firmware from Windows, going back to Mac doesn't make the keyboard work, I'm still required to have Karabiner Elements app running (even after deleting all key mappings from it) to make the keyboard work which seems weird.

So as of now, this keyboard works for me on macOS High Sierra if I keep Karabiner Elements service running. Only thing that doesn't work is Play/Pause & Next/Prev buttons from media controls, even the volume knob works fine!

  • Can you try typing some words within a PC BIOS or very old OS (if you still have Windows XP installed) and see if it is mapped properly? – some user Dec 9 '17 at 7:03
  • @someuser I'm not sure what you mean here, I'm new to Mac, and this keyboard works fine on Windows 7 through 10, and also in Linux. – Kushal Dec 12 '17 at 11:22
  • I am suggesting that you troubleshoot by eliminating any proprietary driver that could be used automatically. BIOS menu is where you press a special key (e.g. F10) during boot. No OS from HDD involved. – some user Dec 14 '17 at 7:02
  • @Kushal any update on the situation? I own this keyboard too and haven't tested it yet on my Mac, but it probably won't work. Did you manage to get it working or somehow map the keys to the correct characters? – Erik Feb 21 '18 at 10:42
  • @Erik I managed to make it functional using Karabiner Elements pqrs.org/osx/karabiner, but again, not all keys map correctly, some keys are completely not being registered by Karabiner, and some keys are registered twice, so I still don't have concrete solution yet. – Kushal Feb 21 '18 at 11:56
6

I had the exact same problem with HyperX Alloy on Mac, and performing a factory reset solved it for me.

You can perform a factory reset of you keyboard by pressing and holding FN + ESC until the keyboard backlight flashes once.

FAQ: KHX-082616-KB-04

  • I just tried factory reset of my hyperx elite alloy (by pressing and holding the three keys in the top left), but it did not help. a still gives h etc. – John Little May 7 '18 at 14:24
  • this did work for me. The keyboard broke from the night to the morning, and i tried it on 2 different macs. This fixed the issue. – Fernando Mazzon Sep 24 '19 at 13:01
3

I actually have an update on this.

I contacted Hyper X/Kingston and they said they said they have an updated firmware. (For both FPS and Elite keebs.)

After I flashed this firmware it worked perfectly. I am typing this post with the new firmware (version 2112). It is best that you contact Hyper X and ask them for the firmware that suits your keyboard.

After updating the firmware all keys work well. The media keys too. The windows key is now the Command key.

You will need a Windows & SP1 PC or above to flash this firmware though

But honestly I think it is Apple's fault for still supporting ADB codes which are so old.

  • Can you point me to firmware update page please? – Kushal Mar 4 '18 at 8:22
  • Ok I managed to download firmware updater from reddit.com/r/MechanicalKeyboards/comments/79qc1l/… which I'm not sure is trusted source, although I went ahead and risked to update firmware and viola! keyboard works on mac!! only thing that baffles me is that I have to keep Karabiner running (even if I delete created mappings from it) as otherwise keyboard doesn't work. – Kushal Mar 4 '18 at 10:38
  • Re: karabiner I am not sure- I dont need karabiner anymore after the firmware update. About the right firmware, since there are different layouts for different keyboards I suggest to contact Hyper X by email with your keyboard model no. Your keyboard model no is below the keyboard on a white sticker – Reno Mar 6 '18 at 19:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.