1

I have moved houses, and thereby internet providers. Choosing a 4G connection rather than a landline, I bought a Huawei B310 for my home network. My LAN is unusual in that I run my own DHCP and DNS in order to run all my traffic over a VPN. In my previous home, this all worked perfectly on Virgin Media.

After ensuring everything is on the correct subnet (192.168.1.0/24), I plugged the B310 into my unmanaged switch and very quickly lost access to the web UI. After tracing to my server, and then to the specific service that kicked the router offline, I was very surprised to see it is isc-dhcp-server (4.3.1-6+deb8u2, running on Debian v8 Jessie). Reproducibly, starting up the daemon causes the router to cease responding to ping after 2-3 seconds.

I have switched off DHCP on the router and this does not cause any problems, but as soon as I switch on my own, the router stops working - it seems to drop all traffic. I have run nmap -Pn 192.168.1.1 and this returns the expected ports, showing them as 'filtered', but the router does not respond to anything. Shutting off DHCP, unplugging ethernet and plugging it back in brings it back.

My question to you network people is - is this actually possible? If so, how? I don't understand how or why the router would care about DHCP working externally. If it's a setting I've gotten wrong, I could accept that, but my understanding of DHCP is that the server simply waits for a request, and at this point everything connected to the switch had an IP assigned. I'm very confused.

  • Which information does your DHCP server send out? Does it include the gateway and nameserver? It's possible that this somehow confuses the router setup (test by removing this information). Does the DHCP server assign the static 192.168.1.1 address to the router, or a dynamic address? Do you have shell access to the router? – dirkt Dec 2 '17 at 7:06
  • @dirkt I use DHCP to override gateway, DNS and domain name, yes. The gateway is the VPN VM that then forwards all traffic. I can try removing it. The DHCP range is .32 onwards and deliberately does not go near .1. This is assigned statically in the router config. I don't have shell access at present but will try your link for the B593 - hopefully the firmware is similar enough. – Gargravarr Dec 2 '17 at 18:03
  • I meant: Does it assign the 192.168.1.1 to the router if the router does a DHCP request (the router does a DHCP request, does it? You checked the logs)? If not, it may screw up the internal config. – dirkt Dec 2 '17 at 18:05
  • In general, it might be a good idea to use wireshark to see what exact exchange of packets causes the router to stop working. – dirkt Dec 2 '17 at 18:06
0

I have solved this problem by setting Ethernet connection mode to "LAN only". Setting can be found here Settings->Ethernet->Ethernet settings.

If it is set to auto it detects DHCP server on LAN port and switches to WAN mode.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.