0

I recently uninstalled Cygwin and switched to using MinGW as my toolchain. I installed the required packages; I triple checked to make sure that mingw32-make, mingw32-gcc and mingw32-gcc-g++ are all installed. This is what CLion says, however, when it tries to detect:

enter image description here

Whenever I try to make a new project, I get multiple CMake errors, like file STRINGS file "C:/Users/me/CLionProjects/project/cmake-build-debug/CMakeFiles/3.9.4/CompilerIdC/a.exe" cannot be read. I looked for the file, and it doesn't exist. What does this mean? What could be causing this?

0

I was also running into this issue today, seems to be a recent windows update. What worked for me was adding "cmake.exe" as a process exclusion in the Windows Defender Security Center.

  • Cmake.exe? Do you mean mingw32-make.exe? – Bluefire Dec 2 '17 at 16:42
  • Adding cmake.exe fixed the error in your question for me. I still get a threat detection warning from windows when trying to build the target though. Also my built exe's don't have an entry point but I am not on my normal dev machine right now, could be a configuration issue on my end. Turning off all real time protection didn't fix this for me either. – Maspe36 Dec 2 '17 at 16:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.