1

I get an error when opening Windows 10 Media Creation Tool: 0x80072F76 - 0X20017.

The tool has just been downloaded from Microsoft's official website and I am trying to run it from a Windows 10 computer.

1

I contacted Microsoft phone support and it is a network error (an error code that appears when Terms and Conditions cannot be displayed for user to read and accept them).

Proposed solutions by Microsoft agent:

  1. Copy installer to Desktop.
  2. Run in Windows 8 compatibility mode.
  3. Run in Windows 7 compatibility mode.
  4. Restart and run in Windows 8 compatibility mode.
  5. Finally, what worked for me: setup network adapter's IPv4 configuration to use DNS server 9.9.9.9.

It is a problem betweeen Microsoft and some ISPs (mainly in Spain), they and working on it but can be bypassed using DNS server 9.9.9.9.

Other solutions I could rean on the Internet (deactivating antivirus, setting default web browser to Microsoft Edge...) didn't work.

  • Does changing DNS work? – Biswapriyo Dec 2 '17 at 18:18
  • @Biswa It worked for me. Seems to be a communication problem between ISP and Microsoft's servers, and using 9.9.9.9 (which, by the way, is an IBM DNS server) you make sure you are connected to a network which is currently working. As said by Microsoft's technician, they are working on a final solution. – user1314836 Dec 4 '17 at 22:46
0

I had the same problem in the US in California, my service provider is AT&T and if I use their DNS 68.94.156.1 and 68.84.157.1 I get the same error when the tool tries to get EULA disclaimer. By changing the DNS to 8.8.8.8 and 8.8.4.4 the problem goes away. Apparently the AT&T DNS does not know the MS server needed for this step.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.