1

I have followed the steps to disable UAC in the Control Panel and rebooted the machine, I use an elevated command prompt but starting cmd.exe with right click -> Run As Administrator and I STILL cannot access a certain particular folder on my C drive which was created by a program (note it is NOT an OS folder/files and in fact, I am able to even access ntoskrnl.exe and hal.dll so there's no reason I shouldn't be able to access this folder). When UAC is enabled, the error is "access denied" and I was unable to even change owner to my user or Admin. Owner was hidden and even the number of files/folder size is hidden. I therefore disabled UAC altogether and I still get access denied errors which say C:\thefolder is not accessible. Access denied How can I get into this folder? Thank you.

Screenshot of situation. Note Admin cmd prompt and also this is with UAC disabled (after reboot): enter image description here

When I try to change owner:

enter image description here

And when I try a takeown with admin prompt:

enter image description here

| improve this question | | | | |
  • Are you the owner of the folder. Provide the ACL or the folder, use a screenshot – Ramhound Dec 3 '17 at 7:27
  • @Ramhound it wont even let me see who the owner is! Updated with screenshot sir. – the_endian Dec 3 '17 at 7:31
  • So you answered your own question. Which is the reason you don’t have permissions to the folder. Forcefully change the owner of the folder you using ‘takeown /f <foldername> /r /d y‘ in an elevated command prompt – Ramhound Dec 3 '17 at 7:38
  • @Ramhound believe it or not, even that says access denied even from an elevated prompt. Hmmm.... – the_endian Dec 3 '17 at 7:42
1

You aren't the owner of the folder, and it's likely you do not have any read permissions of the folder. (This is shown by the access denied, and the 'unable to display current owner' in the permissions window)

You will need to take ownership of the folder first, which will overwrite the permissions and allow you access to the folder.

That said, it's possible the folder (and it's contents) are corrupt, which is erroneously giving the access denied.

also, it's worth noting that some programs set folders in this way to prevent the user tampering with the contents. Changing the permissions may break a program you are relying on.

| improve this answer | | | | |
  • Unfortunately, none of the take ownership mechanisms are working as they are all "access denied" too.... Is it possible to boot into some kind of safemode where I have all access to everything always? Also, I appreciate the concern but I HAVE to get into this folder, I'm a software reverse engineer so not worried about breaking anything. The only other way I can think of, is perhaps using WinDbg or writing a driver to get me in but that's nuts, I should be able to do it from the interface somehow which is why IM asking here. – the_endian Dec 3 '17 at 7:46
  • 5
    if it's not taking the Ownership change then I'd say you've got a fault with the folder. I'd run a check disk on the drive, and see if that turns up any errors. Alternativley, use a linux boot CD to boot the machine, and see if the contents are available there. (NTFS permissions won't apply). – Stese Dec 3 '17 at 7:48
  • BINGO, that LiveCD option worked! Thank you. – the_endian Dec 3 '17 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.