0

I have a 4GB USB Flash Drive which I've accidentally tried to format to FAT (with I think 64k allocation unit, can't remember). After the format completed, the size of the drive changed to 8mb and it's now RAW. I've tried recreating the partition with diskpart and format, but it says the volume size is too low (same directly through cmd), tried using the EaseUs util as well, nothing. It won't let me format it to anything else and keeps failing from the start, I can't run HDDGURU's Low Level Format as it says I have under 65k sectors (EaseUs shows 16k).

Is there anything else I could do to recover the drive? I don't care about data, it's empty, I just want it working again.

Here's the outcome of diskpart:

diskpart results

Here's the HDGURU LLF message: hdguru results

  • 1
    Have you tried to clean the drive and repartition it? It might help to provide some screenshots or output of Windows disk management or from the diskpart list disk and list partition commands. – Appleoddity Dec 3 '17 at 18:56
  • Yeah, tried.. modified to attach a screenshot. – shippers Dec 3 '17 at 19:14
  • That’s strange. To me it looks like the flash drive has failed. – Appleoddity Dec 3 '17 at 19:19
  • Try this Low Level Format Tool – Appleoddity Dec 3 '17 at 19:21
  • 1
    Sorry I missed that. I’d have to say the drive has gone bad. – Appleoddity Dec 3 '17 at 19:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.