0

I am receiving thousands instances of the following error message:

"Mail delivery failed: returning message to sender"

I research this problem and it seems that someone has sent a bunch of these e-mails with my address as a return address. Now, everything that has not been delivered is bounced back to my inbox.

Is there a simple way to stop this? I have a hosting at GoDaddy, but I wasn't able to find any solution there. Can I have some script that will automatically permanently delete these e-mails?

  • 1
    You will not get an answer on this site if you use immoderate language. Please update your question. – AFH Dec 3 '17 at 21:58
  • 1
    No, there's nothing you can do about it (get a good Spam-Filter). – Daniel F Dec 3 '17 at 22:23
  • So you're telling me that the only thing I could do is to delete my e-mail address? Is there something GoDaddy can do to stop this? (I will ask them myself, but their chat is not working at the moment, probably because it is Sunday) – Marko Gulin Dec 3 '17 at 22:25
1

You can't fully eliminate this, however you can (and should) put an SPF record in your domains zone files to advise sites to only accept email coming from mail servers you use. Provided you use the "do not accept other" option this will dramatically cut down the spam others are receiving with your name forged as the sender. and will also discourage spammers from using your email address, as it will greatly reduce the effectiveness of their spam campaign.

Google "SPF record Builder" for some tools which can help you create an appropriate SPF record for your zone, then log in to Godaddy and add it. Make sure you thoroughly test it afterwards.

Its unlikely anyone will help you to build a filter unless you tell them what mail program you are using.

  • I've already checked, and it seems that my domain has an SPF record defined: TXT, @, v=spf1 a mx ptr include:secureserver.net ~all, 1 Hour. What do you mean by "do not accept other", how can I include this? – Marko Gulin Dec 3 '17 at 23:03
  • I mean using "-all" rather then "~all" at the end of your SPF record. ~all means accept other emails without judging them, "-all" means reject emails not from known mail servers. Generally "~all" should be used for testing, and then changed to "-all" when everything is confirmed OK - but lots of people forget the last step. – davidgo Dec 3 '17 at 23:10
  • The ~all was set by default. I've changed the record to -all. Do you maybe know, how long does it take for new settings to update? – Marko Gulin Dec 3 '17 at 23:13
  • No, but an educated guess says it will start working immediately for some people and take up to 1 hour for everyone - thats what the "1 Hour" probably means - ie its the time nameservers should cache that record. – davidgo Dec 3 '17 at 23:14
  • Are you sending your email through the same email provider you are receiving email? (If you are using your ISP's email service you may be breaking things) – davidgo Dec 3 '17 at 23:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.